Installing CUDA drivers on Jetson TX2

Hi, I am wondering if anyone can help me with this issue. I recently got a Jetson TX2 and Econ Systems Hexcam cameras. I was able to install Jetpack on the TX2 with no issues. I also installed opencv (following this instruction: https://jkjung-avt.github.io/opencv3-on-tx2/) and YOLO (https://jkjung-avt.github.io/yolov2/) and it was working fine. So the next thing I did was install the drivers for the Hexcam following the instructions from the company datasheet, which required flashing the Jetson again. However, this completely uninstalled my opencv, YOLO, and even the CUDA drivers. I cannot understand why it would uninstall the CUDA drivers and have sent an inquiry to the company’s tech support.

My workaround to this is to install CUDA manually following this instruction: https://devtalk.nvidia.com/default/topic/1001520/jetson-tx2/setting-up-cuda-manually-on-tx2/.

I was able to get the deb file using my host computer which has Ubuntu 16.04 on it. I copied this deb file to my TX2 as per the instruction and installed it using dpkg -i (deb file) then followed by sudo apt-get install -f to take care of any dependency issues. However, when I do nvcc --version, it says it cannot find CUDA or it is uninstalled. When I try to search for CUDA, all I am getting are these individual deb files for cuda instead of the expected cuda folder in usr/local/cuda. So the next thing I tried to do is to go through these individual deb files and install them using dpkg -i and it all says installation is successful but CUDA is still not found. Does anyone have any advice?

I have no knowledge of those cameras or their driver install information. Do know that JetPack can be run at any time, and everything related to flash unchecked…then check just the packages you are interested in and install those even though something has removed them. Just make sure you use the wired ethernet and can give an address if it is unable to find this automatically. Are you able to use JetPack with flash removed and only packages being added?

@linuxdev: Yes, actually I figured this out like 10 minutes after I posted this and immediately felt silly for not even thinking about that first. I was able to install the drivers without reflashing the TX2 and I was able to install opencv and YOLO as well. Thank you so much for your reply!

Hi,

Is your question solved by using JetPack?
Thanks.