Installing cuDNN DrivePX(1)

I’m trying to install cuDNN on my Drive PX (1). As far as I know the DrivePX comes with CUDA 7.0, so I downloaded cuDNN L4T arm64 for cuda 7.0.
I followed the instructions on how to install the cuDNN but when I tried to compile Caffe or start Theano with cuDNN enabled the linker (ld) saids that it doesn’t find cuDNN files. So I tried with
“ld -lcudnn --verbose” to check where the linker look for its libraries. Even though the LD_LIBRARY_PATH contains the cuDNN library the linker just won’t check that folder. So I basically put the .so and .a files in the folder the linker checked and it worked… kinda. It claims that I downloaded an incompatible version (I downloaded L4T arm64). So then I tried different versions of cuDNN out of desperation and found that Android version arm64 was compatible, but it was missing some library, and I found these on the web and put them along with the other .so files and it loaded… kinda. Here is my output now (with the android arm64 cuDNN)

attempt to open /usr/aarch64-linux-gnu/lib/ failed
attempt to open /usr/aarch64-linux-gnu/lib/libcudnn.a failed
attempt to open /usr/local/lib/aarch64-linux-gnu/ failed
attempt to open /usr/local/lib/aarch64-linux-gnu/libcudnn.a failed
attempt to open /usr/local/lib/ succeeded
-lcudnn (/usr/local/lib/ needed by /usr/local/lib/
found at /lib/aarch64-linux-gnu/ needed by /usr/local/lib/
found at /usr/lib/aarch64-linux-gnu/ needed by /usr/local/lib/
found at /lib/aarch64-linux-gnu/ needed by /usr/local/lib/
found at /usr/lib/aarch64-linux-gnu/ needed by /usr/lib/aarch64-linux-gnu/
found at /lib/aarch64-linux-gnu/ needed by /usr/lib/aarch64-linux-gnu/
found at /lib/aarch64-linux-gnu/
ld: warning: cannot find entry symbol _start; not setting start address

I tried starting theano with cuDNN and python keeps giving me segmentation fault.

Hello iMighty,

Could you please let me know our using platform version DrivePX2 or DrivePX1?
You mentioned you are using Drive PX(1) that means DrivePX2 1ea or DrivePX1?
If DrivePX2, I think you can download the latest DrivePX2 PDK and SDK.
For PX2 cuDNN is packaged as part of TensorRT package. Thanks.


I’m using DrivePX1

Hi again, is it possible to install TensorRT on PX1?

Hi iMighty,

DrivePX1 is really old version HW, could you please update to DrivePX2 to install TensorRT? Thanks.

Hi, we need to use cuDNN on PX2, but we couldn’t find the location of cuDNN.h or such library. How to use cuDNN on PX2? Thanks.

REgarding TensorRT.

Not clear if you are asking about 3.0 RC or an earlier version.

Right now we are still doing QA testing on our version of TensorRT 3.0 RC for Drive PX2. Estimate another week or two before that will be available. The aarch64-linux packages we currently have posted are qualified for Jetson TX1 and TX2 but not for Drive PX2.

If you are asking about an earlier version, yes TensorRT 2.1 should be available via the drive install mechanism for Drive PX 2. We are not qualifying/supporting it for Drive PX1.