Installing DeepSpeech tflite 0.9.3 on Nvidia Jetson Nano (Jetpack 4.5.1) [GUIDE]

All,
I was having a heck of a time figuring this out (spent past two days going further down a rabbit-hole trying to compile, cross-compile, etc.) when I realized it was really simple.

Mozilla provides a release for Linux aarch64 that in theory should have worked with the Jetson Nano’s ARM64: https://github.com/mozilla/DeepSpeech/releases/download/v0.9.3/deepspeech-0.9.3-cp37-cp37m-linux_aarch64.whl

But it I would always get an error saying the platform wasn’t supported.

Then (feeling dumb in my ignorance) tried to figure out what the “cp37” meant in the wheel file, and I felt like an even bigger dummy when I learned that cp## in wheel filenames refers to python version!

That’s when it finally clicked that python3 on the Nano is python 3.6, but this wheel requires python 3.7.

Once I had that figured out, the below worked like a charm:

First install python 3.7 on your Nano (make sure to get the dev branch otherwise Deepspeech’s C++ → python bindings won’t work an you’re gonna have a bad time)
sudo apt-get install python3.7-dev

Then download the deepspeech 0.9.3 wheel from here: https://github.com/mozilla/DeepSpeech/releases/download/v0.9.3/deepspeech-0.9.3-cp37-cp37m-linux_aarch64.whl

Then install deepspeech by calling pip with python3.7:
python3.7 -m pip --install deepspeech-0.9.3-cp37-cp37m-linux_aarch64.whl

After that, download the following:

Finally you can test the whole thing out with the following command (change audio file to test against the others):
deepspeech --model deepspeech-0.9.3-models.tflite --audio audio/2830-3980-0043.wav --scorer deepspeech-0.9.3-models.scorer

Great! Thanks for your sharing to the community!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.