Installing Driver 352.41 on Ubuntu Linux

I tried to install this version of the driver to better provide support for shading, but during the installation it came up with the message “distro provided preinstall script failed”. I continued, but after it successfully (allegedly) installed, my whole graphics experience was impacted, and laggy. I found out that the message “Xlib: extension “GLX” missing on display “:0.0”.” on several applications and some - such as Steam refused to start.

How do I fix this problem?