Installing driver issue

Been reading so much here aobut the same issue and still can’t figure it out.
Here’s the bug report nvidia-bug-report.log.gz (454.6 KB)

nvidia-persistenced[52355]: Failed to query NVIDIA devices. Please ensure that the NVIDIA device files (/dev/nvidia*) exist, and that user 130 has read and write permissions for tho
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
dkms status
nvidia, 525.60.11, 5.15.0-46-generic, x86_64: installed
nvidia, 525.60.11, 5.15.0-57-generic, x86_64: installed

(I’m not sure hwy it shows 2)

I tried installing from the built in GUI, and also from the command line with sudo ubuntu-drivers autoinstall everything yield the same results

For some reason, the driver packages failed to blacklist nouveau, please create /etc/modprobe.d/nouveau-blacklist.conf

blacklist nouveau

and run
sudo update-initramfs -u

Thank you for your reply!

I was reinstalling stuff but still same issue, I added the file you described and still no success. Adding the new log
nvidia-bug-report.log.gz (302.5 KB)

Kernel driver in use: nouveau

[ 812.773733] NVRM: The NVIDIA probe routine was not called for 1 device(s).
[ 812.774410] NVRM: This can occur when a driver such as:
NVRM: nouveau, rivafb, nvidiafb or rivatv
NVRM: was loaded and obtained ownership of the NVIDIA device(s).
[ 812.774411] NVRM: Try unloading the conflicting kernel module (and/or
NVRM: reconfigure your kernel without the conflicting
NVRM: driver(s)), then try loading the NVIDIA kernel module
NVRM: again.

Still nouveau is used.
Make sure the blacklist file exists. Also make sure nvidiafb is blacklisted.
Re-generate your initramfs, as generix told you. Reboot.