Installing driver Linux x86_64-390.132 on fedora-31

Hello .
I’ve got some trouble for installing Linux driver.
It’s about a Bad version of GCC compiler.
Mine is newer that the ones wich compile the kernel before.
I did prefere to abort installation however it seems to be possible to resume.
Could you take a look on the install log file and tell me more about this failure?
With great thanks in advance for your attention.
Best regards .
FWRnvidia-installer.log (1.3 KB)

What kind of information do you need? Didn’t the installer ask you whether to abort or not?
Major gcc version mismatches (e.g. v8 vs. v9) tend to render the modules unusable, minor mismatches like in your case most often work. You’ll have to try and see, there’s no guarantee, depends on the changes the gcc devs implemented.

Ok. Sir.
Great thanks for answers.

I passed over the mistake I’d tell before with using the command Line

#CC=/usr/bin/gcc-9.2
#export CC

Then the installation programm passes over the gcc check.

Now I,ve got a new message that tell me about kernell sources.
I’ll post the installer log file later after back it up on my smartphone.

Read you soon.
Best regards.

FWR

I got It.
You Can pick it up below.

I do not understand the mistake because before installing drivers I did

#dnf groupinstall “Development Tools”
#dnf install libglvnd-devel

I look into /lib/modules…
There are 2 files.
5.3.7-301.fc31.x86_64
5.5.11-200.fc31.x86_64

And
#uname -r gives me

5.5.11-200.fc31.x86_64

Do I remove the 5.3.7-301. ?
I don’t think it’s a good Idea.

I do not understand the end of the message where it’s told:

If you know the correct kernel source files are installed, you may specify the kernel source path with the ‘–kernel-source-path’ command line option.

Thanks in advance for attention and Help

Best regards

FWR

2nd-nvidia-installer.log (1.2 KB)

The headers for the currently running kernel are missing. Install it using

sudo dnf install "kernel-devel-uname-r == $(uname -r)"

You shouldn’t remove any module directories by yourself.

I understand that I Can run the installer with an option.
I should type the command:
#./NVIDIA-Linux-x86_64-390.132.run --kernel-source-path=usr/src/kernels/5.5.13-200.fc31.x86_64

No. The error message says that that path was given by the system but nothing was there.

Thanks.
I did #dnf update
so i’ve got a New kernel
I check
#dnf install "kernel-devel…
It’s ok

Now i’ve got in source path:
/usr/src/kernel/5.5.13-200.fc31.x86_64

I 'd like to try the option --kernel-source-path=/usr/src/kernel/5.5.13-200.fc31.x86_64 of the installer