Installing Driveworks within a docker image

Good to hear!

In the meantime I have made one small addition: you will need to add the sshpass package to the apt-get install list, it is needed to get make upload work, to transfer the crosscompiled examples to the PX2 as described in the configuration.

Just for your information: NVIDIA added a post regarding DriveWorks in a docker image in the FAQ-Area of this forum at https://devtalk.nvidia.com/default/topic/1030912/faq/installing-driveworks-within-a-docker-image/

Hi Sandervandijk,

I follow your step try to build driveworks in docker image, but I don’t have PX2 devices so I can not flash.

After that, I get WARNING message
“WARNING: DriveInstall returned an error code…”

I check the path of DRIVE_INSTALL, it’s ok.
In DriveInstall_5.0.5.0aL_SDK_b19.run folder, the _installer is Uncompressing by the the script too.

Do I really need connected with PX2 to let script download driveworks host packages to docker image?

Hey Arlen, as the rest of the warning message says things should be fine, if this happened when the installer got to the stage of trying to flash the PX2: all other installation steps are run before that. Have you tried the steps to build the samples and run the ‘hello, word’? If you don’t get an issue there, you should be good, else let us know!

Hi Sandervandijk,

Actually… there’s no /usr/local/driveworks/samples/ in my docker image…

Here is my screenshot after run script and go into docker.

https://drive.google.com/open?id=10aPMShXUbwE1zR61GMDZqd_ROxWVxV2t

You can see driveworks images size is very small in docker images part…

Should I get any GUI operation when running DriveInstall_5.0.5.0aL_SDK_b19.run?

DW SDK is still not installed in your docker container.
you can start your docker and execute the installation manually.
You can stop the process in the GUI, choose “no action” for flashing device and install cuda on target, mark auto resolve dependency and then start the process again.

Hi ba.quang.vinh.cao,

No any GUI show up when I execute ./DriveInstall_5.0.5.0aL_SDK_b19.run in docker container

It’s just show Creating directory _installer but no next GUI operation.

this is important to get the GUI showing up: docker run -ti -e DISPLAY=$DISPLAY -v /tmp/.X11-unix:/tmp/.X11-unix --privileged

I have difficulties to install the SDK on my docker image using DriveInstall.run.
I have the exact same problem as ba.quang.vinh.cao. I tried what solved the problem for him (sudo apt install libgtk2.0-0) without success as well as all the solutions proposed on this topic.
Here are the last lines I get from the script used to run the docker image:
Creating directory _installer
Verifying archive integrity… 100% All good.
Uncompressing DriveInstall 100

I get the same result when launching the DriveInstall*.run from the docker image…
I guess my problem comes from the graphical capability of my docker image but I can’t find the solution.

=> Config:
Ubuntu 16.04
docker-nvidia
DriveWorks 5.0.5.0a

I was able to install Driveworks 0.5 on nvidia-docker. However, for Driveworks 1.0, when I try to install it on the same docker machine with the command: ‘./sdkmanager’ I get no answer. And when I write ‘sudo ./sdkmanager’, I get an error ‘Nvidia SDK Manager crashed unexpectedly. Relaunch or exit?’.

Any tricks similar to previous installation which were really very helpful?

Hi Ozgur,

Have you installed DriveWorks 0.5 on nvidia-docker using the exact steps and commands
described by sandervandjik ?
If you performed some modifications or additions, it would be glade that you share it with me <3 (see my comment above). Because I can’t launch the DriveWorks installer’s GUI.

Hi bcollado,

I made some modifications depending on my needs. This step is same:
/usr/share/polkit-1/actions/org.freedesktop.policykit.policy

change allow_any,allow_inactive,allow_active to yes

sudo /etc/init.d/dbus stop
sudo /etc/init.d/dbus start

There is an undocumented problem which can happen, if the folder “/usr/local/nvidia/” is write-protected, (try to create folder “mkdir -p /usr/local/nvidia/mycheck” to check and it should give you a no permission error only, otherwise) mount it properly via:

mount -o remount,rw /usr/local/nvidia/

After this, I followed the steps:

For installation:

cd ~/install/DriveWorksSDK/
./DriveInstall_5.0.5.0bL_SDK_b3.run

I installed only Host: Click ‘Next’ 3 times, select ‘Clear Actions’, Select ‘DriveWorks on Host’ (by changing no action -> install). Then click Next. During installation, you can verify from terminal at the bottom of the page that ‘TensorRT on Host’ is installing properly. (If ‘/usr/local/nvidia’ is write-protected, then this will fail without warnings. Then do the mounting again and repeat Driveworks installation step again.) Click Next and Finish. To check your installation:

mkdir build
cd build
cmake -DCMAKE_BUILD_TYPE=Release /usr/local/driveworks/samples/
make -j
./src/hello_world/sample_hello_world

Dear developpers,

In an attempt to install the DriveWorks DSK on a docker image, I would need some help on a particular issue:
My disk space being limited, I need to run the DriveInstall.sh script in non-silent mode, i.e with the possibility to unselect unnecessary packages to save memory.
The problem is that the installation doesn’t start when I customize packages. The installer is stuck.
Does somebody have advises on this particular issue ?
Thank you.

Best regards

It seems that with the new SDKManager GUI, we cannot follow the docker workflow documented in this thread anymore.

Just answered the question regarding the DRIVE Installation by using a docker container and facing memory issues on https://devtalk.nvidia.com/default/topic/1043762/driveworks/driveinstall-stuck-when-customizing-packages-installation-/?offset=2#5296679.

Since this thread has three pages of answers and is based on DW 0.5, I do suggest to open a new thread for DW 1.2 problems.

  • Fabian