Installing Dropbox on a Jetson TX2

Hi folks,

I have tried to install dropbox on TX2 and it is not as straightforward as I thought.

Has anyone been through this process with success ?

For now, I have unsucessfully:

  1. tried the easy installation on ubuntu from https://www.dropbox.com/fr/install-linux
  2. tried to compile from sources following those directives: https://help.dropbox.com/fr-fr/installs-integrations/desktop/linux-commands

Help and shared experience appreciated,
Emmanuel

  • cortexia.ch

Some more information

1. APT

Once you have properly added the dropbox repo and its key, the issue is kind of straightforward: arm64 is not supported

$ sudo vi /etc/apt/sources.list
  -> deb http://linux.dropbox.com/ubuntu xenial main
$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1C61A2656FB57B7E4DE0F4C1FC918B335044912E
$ sudo apt update

Error Message:
N: Skipping acquire of configured file ‘main/binary-arm64/Packages’ as repository ‘http://linux.dropbox.com/ubuntu xenial InRelease’ doesn’t support architecture ‘arm64’

2. compiling from sources

$ sudo apt install libnautilus-extension-dev python3-docutils
$ wget https://linux.dropbox.com/packages/nautilus-dropbox-2019.02.14.tar.bz2
$ tar xjf nautilus-dropbox-2019.02.14.tar.bz2
$ cd nautilus-dropbox-2019.02.14
$ ./configure
$ make
$ sudo make install

It looks good so far… but the problem comes with the next post

I am now hitting another issue, when trying to setup my dropbox…

it looks like a dead end…

$ dropbox start -i
Starting Dropbox...
Dropbox is the easiest way to share and store your files online. Want to learn more? Head to https://www.dropbox.com/

In order to use Dropbox, you must download the proprietary daemon.

Error: Platform not supported
Traceback (most recent call last):
  File "/usr/bin/dropbox", line 1443, in start
    download()
  File "/usr/bin/dropbox", line 571, in download
    for progress, status in download.copy_data():
  File "/usr/bin/dropbox", line 225, in copy_data
    return download_file_chunk(DOWNLOAD_LOCATION_FMT % plat(), self.local_file)
  File "/usr/bin/dropbox", line 131, in plat
    FatalVisibleError("Platform not supported")
  File "/usr/bin/dropbox", line 536, in FatalVisibleError
    sys.exit(-1)
SystemExit: -1

Eventually, I chose to install https://rclone.org/, which handles synchronisation with dropbox