Installing error, deepstream-binding Prerequisites gst-python

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) jetson xavier nx : PE1000N + I also mounted a 256GB NVMe.
• DeepStream Version : 6.2
• JetPack Version (valid for Jetson only) : 5.1.1 L4T[35.3.1]
• TensorRT Version :
• NVIDIA GPU Driver Version (valid for GPU only) x
• Issue Type( questions, new requirements, bugs) : Execution error
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing) : text for code
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description) : deepstream python binding, python test usb cam.

The result of running the deepstream_python_apps example.
I seem to have missed something with the Unknown black screen floating around. what action should i take?

Missing pyds module mean python-binding of DeepStream isn’t installed successfully.

Maybe you need this documention

This didn’t work for me. Are there other alternatives?

Did you compile pyds from source ?

Can you got output from the following command ?

 pip3 list|grep pyds

There are same error as yours

pip install pyds-1.1.6-py3-none-linux_x86_64.whl
I installed pyds through this. But I seem to be getting the same error.

What is the default python version of your system ?

What is the output of the following command ?

 python --version

Can you try the below command

 python3 -m pip install pyds-1.1.6-py3-none-linux_aarch64.whl

This error only appears if pyds isn’t installed correctly

my python version 3.8.10

and i ran

python3 -m ipi install pyds-1.1.6-py3-none-linux-aarch64.whl --force-reinstall

I was able to run test usb cam successfully. thank you :D !!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.