Installing intel 9560NGW wifi card on Xavier Jetpack 5.0

Hi, I am trying to install intel 9560NGW wifi card, but the dmesg gives me this message “Failed to get slot regulators: -517”.

[ 4.875326] tegra194-pcie 14180000.pcie: Adding to iommu group 7
[ 4.885841] tegra194-pcie 14180000.pcie: host bridge /pcie@14180000 ranges:
[ 4.888116] tegra194-pcie 14180000.pcie: IO 0x0038100000…0x00381fffff → 0x0038100000
[ 4.896517] tegra194-pcie 14180000.pcie: MEM 0x1800000000…0x1b3fffffff → 0x1800000000
[ 4.905076] tegra194-pcie 14180000.pcie: MEM 0x1b40000000…0x1bffffffff → 0x0040000000
[ 5.021166] tegra194-pcie 14180000.pcie: Link up
[ 5.024050] tegra194-pcie 14180000.pcie: PCI host bridge to bus 0000:00
[ 5.060114] pcieport 0000:00:00.0: Adding to iommu group 7
[ 5.061718] pcieport 0000:00:00.0: PME: Signaling with IRQ 24
[ 5.063381] pcieport 0000:00:00.0: AER: enabled with IRQ 24
[ 5.073128] tegra194-pcie 14100000.pcie: Adding to iommu group 8
[ 5.087544] tegra194-pcie 14100000.pcie: host bridge /pcie@14100000 ranges:
[ 5.095384] tegra194-pcie 14100000.pcie: IO 0x0030100000…0x00301fffff → 0x0030100000
[ 5.103822] tegra194-pcie 14100000.pcie: MEM 0x1200000000…0x122fffffff → 0x1200000000
[ 5.111959] tegra194-pcie 14100000.pcie: MEM 0x1230000000…0x123fffffff → 0x0040000000
[ 5.229237] tegra194-pcie 14100000.pcie: Link up
[ 5.232503] tegra194-pcie 14100000.pcie: PCI host bridge to bus 0001:00
[ 5.357748] pcieport 0001:00:00.0: Adding to iommu group 8
[ 5.362724] pcieport 0001:00:00.0: PME: Signaling with IRQ 26
[ 5.368175] pcieport 0001:00:00.0: AER: enabled with IRQ 26
[ 5.375172] tegra194-pcie 14140000.pcie: Adding to iommu group 9
[ 5.382817] tegra194-pcie 14140000.pcie: host bridge /pcie@14140000 ranges:
[ 5.385697] tegra194-pcie 14140000.pcie: IO 0x0034100000…0x00341fffff → 0x0034100000
[ 5.394472] tegra194-pcie 14140000.pcie: MEM 0x1280000000…0x12afffffff → 0x1280000000
[ 5.402807] tegra194-pcie 14140000.pcie: MEM 0x12b0000000…0x12bfffffff → 0x0040000000
[ 6.505254] tegra194-pcie 14140000.pcie: Phy link never came up
[ 6.505914] tegra194-pcie 14140000.pcie: PCI host bridge to bus 0003:00
[ 6.536115] pcieport 0003:00:00.0: Adding to iommu group 9
[ 6.537867] pcieport 0003:00:00.0: PME: Signaling with IRQ 28
[ 6.539265] pcieport 0003:00:00.0: AER: enabled with IRQ 28
[ 6.545657] tegra194-pcie 141a0000.pcie: Adding to iommu group 10
[ 6.547452] tegra194-pcie 141a0000.pcie: Failed to get slot regulators: -517
[ 7.363735] tegra194-pcie 141a0000.pcie: Failed to get slot regulators: -517
[ 7.809435] tegra194-pcie 141a0000.pcie: host bridge /pcie@141a0000 ranges:
[ 7.816520] tegra194-pcie 141a0000.pcie: IO 0x003a100000…0x003a1fffff → 0x003a100000
[ 7.831656] tegra194-pcie 141a0000.pcie: MEM 0x1c00000000…0x1f3fffffff → 0x1c00000000
[ 7.846109] tegra194-pcie 141a0000.pcie: MEM 0x1f40000000…0x1fffffffff → 0x0040000000
[ 8.953133] tegra194-pcie 141a0000.pcie: Phy link never came up
[ 8.953408] tegra194-pcie 141a0000.pcie: PCI host bridge to bus 0005:00
[ 8.966817] pcieport 0005:00:00.0: Adding to iommu group 10
[ 8.967351] pcieport 0005:00:00.0: PME: Signaling with IRQ 30
[ 8.967823] pcieport 0005:00:00.0: AER: enabled with IRQ 30
[ 39.905184] vdd-3v3-pcie: disabling
[ 39.905188] vdd-12v-pcie: disabling

pcie-regulator.patch (1.0 KB)
pls have a try with the above patch.

Hi, any tips when applying patch ? I tried using patch -p < pcie-regulator.patch, but no matching file was found. Then I tried looking for tegra234-p3737-overlay-pcie.dts myself but without any success.

Have you try with JP5.0.1?

Yes. I didn’t help. But 8265 worked.