Installing Jetpack 3.2 on Ubuntu 18.04

I’m unable to install Jetpack on xUbuntu 18.04. I tried editing /etc/lsb-release to change the version number to 16.04, and I also tried editing the start_up.sh file inbetween running it with --confim argument. Here is the output I get when running with --confirm:

./JetPack-L4T-3.2-linux-x64_b196.run --confirm
Creating directory _installer
Verifying archive integrity... All good.
About to extract 110480 KB in _installer ... Proceed ? [Y/n] y
Uncompressing JetPack  100%  
OK to execute: ./start_up.sh >/dev/null 2>&1  ? [Y/n] y
The program './start_up.sh' returned an error code (127)

Probably some old version of some shared library that’s missing, because JetPack is only supported up to 16.04.
You can diagnose program problems with “ldd” and “strace”
You may need to look into the start_up.sh script and add the commands there to trace the right thing.

Try this:

sudo wget -q -O /tmp/libpng12.deb http://mirrors.kernel.org/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.54-1ubuntu1_amd64.deb
&& sudo dpkg -i /tmp/libpng12.deb
&& sudo rm /tmp/libpng12.deb

This was it! Thank you!

Indeed it was. Thank you so much.

Now see if they have sorted out the passwods and screens and windows nightmare

The pre-built 64-bit gcc 4.8.5 tool chain in the nvidia download center failed to build the linux kernel on Ubuntu 18.04. However, the gcc-linaro-4.9.4-2017.01-x86_64_aarch64-linux-gnu.tar.xz tool chain from https://www.linaro.org/downloads/ seemed to work. Is there any significant differences between the nvidia tool chain and the linaro version?

I can’t say for certain, but most of the toolchains are actually Linaro or some predecessor of Linaro (and Linaro strives to be a pure port of the gcc mainline releases ported to ARM). A more relevant question might be “what’s the difference between 4.8.5 and 4.9.4?”. Just as speculation, perhaps the difference is not so much the compiler, but instead something provided by the sysroot or runtime. Sometimes it is also a case of one version marking a certain condition as a warning, while the other version considers it an error. You’d need to post the exact error message to narrow it down.

Perfect, Thanks.

Also thanks from me. JetPack 3.3 installed on Ubuntu 18.04 with this knowledge.

Thanks. This also works with JetPack 3.3 on Linux Mint 19 (based on Ubuntu 18.04).

Hi, Confirmed it works for me as well ;).

With a minimum install Ubuntu 18.04 you need to install xterm and python before installing JetPack 3.3

Does not work on wsl and VirtualBox

VMs usually fail. When VMs do not fail it seems they have been tuned to fix losing USB (USB re-enumerates during the flash…even if you see the TX2 with lsusb before starting you have to guarantee that as USB goes away and comes back the VM always has ownership, and not the host).

I’m trying to flash JetPack 3.3 on Ubuntu 18.04 and I always get stuck in “Determining the IP address of target…” no matter what I try. Can someone confirm that this should work on Ubuntu 18.04 after that libpng12 trick…?

Usually you can find a prompt in the console asking for the IP address. If you see that, then you can enter manually. You can uncheck the flash step and run this other step over wired ethernet at any time, and usually will need to manually enter the IP address. Flash itself will try to set up a one-time mechanism for the Jetson to report its IP to JetPack, but even that can fail. In part it depends on whether you checked to have the host act as router or if you have an actual router appliance. In the case of a host which is a VM you’re pretty much guaranteed it won’t work right without some special setup.

Do you see a console, and can you see a prompt there asking for IP address? Did you use a router appliance on wired ethernet, or did you use the host PC as a router?

Thank you so so much. After run it, I can install JetPack 3.3 now. you made my day