Installing MT7601U Linux driver

Could you give me some help to install MT7601U Linux driver on TK1?
(https://github.com/muratdemirtas/MT7601u, I got error…)

Is there anyone tried?

What kernel version was this module intended for? The R21.5 release uses a 3.10.40 kernel, is the module for a 4.x series kernel?

@linuxdev

Thanks for your answer, I can not find exact mt7601u driver for 3.10.40 kernel but I find repo which testd for 3.xx( https://github.com/alfmel/mt7601 )

I think we should change here, https://github.com/alfmel/mt7601/blob/master/src/Makefile

LINUX_SRC = /home/ralink-2860-sdk-5vt-distribution/linux-2.6.17
CROSS_COMPILE = /opt/crosstool/uClibc_v5te_le_gcc_4_1_1/bin/arm-linux-

Could I get help?

Thanks.

The 2.6.17 kernel is fairly different from a 3.x series, you might want to ask the people who released the driver if there are patches for a 3.x series kernel, or perhaps find out if the kernel this is built against has a published config to start with.

Thanks agin. I read they works on patches for a 3.x series…

BTW, Is it okay if i run below? I worried about if this change the code for PC ubuntu, not for LFT

#setup dependencies
sudo apt-get install --reinstall linux-headers-generic build-essential

This will run on the machine you run it from. Run it from the Jetson, and it applies to the Jetson…run it from the PC, and it applies to the PC.

NOTE: On the Jetson I don’t know if the “/usr/src/linux-headers-3.10.40-ga7da876/” content is owned by a package…I didn’t see it with “dpkg -S”, I suspect apt-get won’t be correct.