Installing multiple cudnn version on host machine

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
[+] DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
[+] Linux
QNX
other

Hardware Platform
[+] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
[+] 1.8.0.10363
other

Host Machine Version
[+] native Ubuntu 18.04
other

Hi team,

I wanted to do some other neural network training on my host pc where I have installed drive related softwares using SDK manager. I understand I have cudnn version 7.6.6 as per sdk manager installation

But I need cudnn greater than 8.1 for a specific neural network training. What I tried,

  1. Tried mapping lib64 path of newly downloaded cudnn 8.4 in LD_LIBRARY_PATH
  2. Tried copying lib and include files to usr/local/cuda lib and include paths (asper cudnn installation manual by nvidia)
  3. Tried copying lib and include files of new version to usr/include/x86_64-linux-gnu and usr/lib/x86_64-linux-gnu

None of the above worked for me. My system still detecting cudnn 7.6.6.

is there any way in which my host pc can detect new version of cudnn.

NB: I dont have any other pc with GPU for trying other than host pc

Hi,

Could you share how you detect the cuDNN version?

If it is reported by the inference frameworks (ex. TensorFlow or PyTorch), you will need to install a package that is compiled with the newer cuDNN library.

Thanks.

1 Like