Installing NVIDIA-Linux-x86-331.38.run left my Linux OS unusable

I have Nvidia GeForce 960 GT card.

  1. Downloaded driver.
  2. Made it executable.
  3. Closed down the X service with service lightdm stop.
  4. Logged in as su.
  5. Ran the driver install.
  6. Restarted and found the os refused to complete its loading sequence.
  7. Left with a black screen and a blinking cursor in the top left corner.

Any suggestions what I do next other than re-install the os from cd?

$ su -
# nvidia-uninstall
# reboot

Most likely you forgot to disable/black-list nouveau that’s why NVIDIA’s drivers cannot start/work.

How that can be done? Read your distro manual/docs/how to.

BTW, your card is pretty weak by today’s standards - what for do you need a binary blob? Besides 9600 GT doesn’t support power management, thus nouveau should have a decent speed.

Ragwin, does pressing Alt+F1, Alt+F2, etc. bring up a login prompt? If so, please run nvidia-bug-report.sh before following birdie’s suggestion of uninstalling the NVIDIA driver and then attach the resulting nvidia-bug-report.log.gz file here.

I don’t see the creating of a xorg.conf stanza in the steps.

Yes, I was reading that the conflict with nouveau would be an issue. Thanks for confirming that.

The card still provides decent graphics quality and speed for my general use. The Windows installer does provide a fancy power management tool.

No, I wasn’t getting a login prompt. I’ve read up about Linux black boot screens and see it can be resolved by editing the grub bootup script and changing quick-splash to nomodeset.

Ctrl+Alt+F1 does turn off the X windows and leave me with a basic prompt.

I’ll hunt down the nvidia-bug-report.log.gz when I can get in.

An xorg.conf stanza is new to me. Presumably the config settings for the X window interface.

I’ve read about several different methods for installing nvidia drivers. It’s not clear to me which of these methods is the one I should be using. At first I used the Additional Drivers options in the Linux Software Center to switch from Nouveau to using the Nvidia binary Xorg driver from the VDPAU library version 310. (I cannot remember how I installed those additional drivers). This worked but leaves black screens on windows sometimes and fps rates in an OpenGL game were not particularly good. So I decided to try a more manual install.

I see can change the boot behavior by altering the etc/default/grub file and setting GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nomodeset” followed by sudo update-grub.

Or perhaps I need?

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nouveau.nomodeset=0”

to prevent a conflict with the nouveau driver.

Recovered the os to use the 310 drivers from the Software Center->Additional Drivers. Now attempting to re-install 331.

Documentation says “If nvidia-installer detects Nouveau is in use by the system, it will offer to create such a modprobe configuration file to disable Nouveau.”

I’ll take more notice of that this time.

I’ve re-installed 331.38 and it’s resulted in the same black screen on boot up.

  1. Booted in under text mode.
  2. Created a disable-nouveau.conf file in /etc/module.d.
  3. Ran the 331.38 run file.
  4. Ran nvidia-xconfig.
  5. Rebooted into X server (I use Zorin which is uses a lightdm X server). Grub setting of quiet splash.
  6. OS booted into text mode first (?) and then straight to a black screen.

The installation procedure did produce errors. nvidia-installer.log is attached.

nvidia-installer.log (11.8 KB)

3rd attempt at install of 331.38 worked for me. I now have 331.38 working with a GeForce 9600 GT.

  1. Booted in under text mode.
  2. Ran sudo apt-get remove --purge nvidia*.
  3. Created a disable-nouveau.conf file in /etc/module.d.
  4. Ran the 331.38 run file.
  5. Ran nvidia-xconfig.
  6. Rebooted into X server (I use Zorin which uses a lightdm X server).
  7. Used Grub setting of quiet nosplash for reboot.
  8. OS booted straight into X service (lightdm).

It was the swapping from splash to nosplash in the Grub config file that seemed to make the difference. Not sure if that means I can now switch it back to splash.

It is generally a bad idea to try to install nvidia’s *.run package on most modern distributions. Installing by the package manager is better. If the latest version isn’t in the repository, you can check out PPAs like the Xorg Crack Pushers PPA (https://launchpad.net/~xorg-edgers/+archive/ppa), which usually has the most recent version in it.

Yes I later performed a package install with add-apt-repository from xorg-edgers. But this only gave me 331.20 and it still gave me the intermittent black window problem after installation. My manual install effort did not have this issue.

Well from what I had to do to solve this problem, not sure if it will work for you is to remove bumblebee. I read this from another forum.

edit: I have a 550 GTX Ti

apt-get --purge remove bumblebee