Installing OV Create fails: physicalDevices must be a valid array of physical devices for a non-zero count

I am trying to install OV Create on a WIN10 desktop machine which have 2 GTX 1080 Ti, driver version 472.39. (See attachment for more info on the driver)

However, I am getting the following error:

Error occurred during installation of Create: Command failed: “C:\Users\agbaria\AppData\Local\ov\pkg\create-2021.3.6\omni.create.warmup.bat” --/app/environment/name=‘launcher_warmup’

2021-11-04 06:09:38 [2,839ms] [Error] [carb.graphics-direct3d.plugin] physicalDevices must be a valid array of physical devices for a non-zero count.

2021-11-04 06:09:38 [2,840ms] [Error] [carb.graphics-direct3d.plugin] createDeviceGroup failed to create a device.

2021-11-04 06:09:44 [8,417ms] [Fatal] [carb.crashreporter-breakpad.plugin] gpu.foundation.dll!carbOnPluginShutdown

2021-11-04 06:09:44 [8,417ms] [Fatal] [carb.crashreporter-breakpad.plugin] gpu.foundation.dll!carbOnPluginShutdown

2021-11-04 06:09:44 [8,417ms] [Fatal] [carb.crashreporter-breakpad.plugin] gpu.foundation.dll!carbOnPluginShutdown

2021-11-04 06:09:44 [8,418ms] [Fatal] [carb.crashreporter-breakpad.plugin] omni.gpu_foundation_factory.plugin.dll!+0x1e63

2021-11-04 06:09:44 [8,418ms] [Fatal] [carb.crashreporter-breakpad.plugin] omni.kit.renderer.plugin.dll!carbOnPluginStartup

2021-11-04 06:09:44 [8,418ms] [Fatal] [carb.crashreporter-breakpad.plugin] omni.kit.renderer.plugin.dll!carbOnPluginStartup

2021-11-04 06:09:44 [8,419ms] [Fatal] [carb.crashreporter-breakpad.plugin] omni.kit.renderer.ext.plugin.dll!+0x19de

2021-11-04 06:09:44 [8,419ms] [Fatal] [carb.crashreporter-breakpad.plugin] omni.ext.plugin.dll!carbOnPluginRegisterEx

2021-11-04 06:09:44 [8,420ms] [Fatal] [carb.crashreporter-breakpad.plugin] omni.ext.plugin.dll!carbOnPluginRegisterEx

2021-11-04 06:09:44 [8,420ms] [Fatal] [carb.crashreporter-breakpad.plugin] omni.ext.plugin.dll!carbOnPluginStartup

2021-11-04 06:09:44 [8,420ms] [Fatal] [carb.crashreporter-breakpad.plugin] omni.ext.plugin.dll!carbOnPluginRegisterEx

2021-11-04 06:09:44 [8,420ms] [Fatal] [carb.crashreporter-breakpad.plugin] omni.ext.plugin.dll!carbOnPluginRegisterEx

2021-11-04 06:09:44 [8,420ms] [Fatal] [carb.crashreporter-breakpad.plugin] omni.ext.plugin.dll!carbOnPluginRegisterEx

2021-11-04 06:09:44 [8,420ms] [Fatal] [carb.crashreporter-breakpad.plugin] omni.ext.plugin.dll!carbOnPluginStartup

2021-11-04 06:09:44 [8,421ms] [Fatal] [carb.crashreporter-breakpad.plugin] omni.kit.app.plugin.dll!+0xf833

2021-11-04 06:09:44 [8,421ms] [Fatal] [carb.crashreporter-breakpad.plugin] omni.kit.app.plugin.dll!+0xb4d1

2021-11-04 06:09:44 [8,422ms] [Fatal] [carb.crashreporter-breakpad.plugin] kit.exe!+0x21ef

2021-11-04 06:09:44 [8,422ms] [Fatal] [carb.crashreporter-breakpad.plugin] kit.exe!+0x2c64

2021-11-04 06:09:44 [8,422ms] [Fatal] [carb.crashreporter-breakpad.plugin] KERNEL32.DLL!BaseThreadInitThunk

2021-11-04 06:09:44 [8,422ms] [Fatal] [carb.crashreporter-breakpad.plugin] ntdll.dll!RtlUserThreadStart

hello @ahmad.agbaria -
Omniverse Create does require RTX capable cards. Your GTX GPUs will not work. Each application in Omniverse has a requirement page for details. Here is an example of Create in Launcher exchange tab :