installing PGI VF 2008 on Windows XP x64

Hi,
Every time I try to run the setup file pgivfx64-08-724.exe on my win XP x64 machine I get an error message saying

Error:1628 failed to complete installation.

I have updated my windows installer service to latest version 4.5 but every time I run the setup I get the error message. Please help me installing it.

I don’t have MS Visual Studio 2005/08 already installed. Could that be the problem.

Hi srb.rastogi,

Unfortunately, I believe you have run into a Windows issue (See: http://support.microsoft.com/kb/925336) in which a security enhancement installed with IE7 causes large installs, such as PVF, to fail to properly read the package’s digital signature. While we have not been able to reproduce the problem here, other users have been able to work around the problem by either removing IE7, changing a registry setting as suggested by Microsoft, or install the smaller 7.1-5 version of PVF Complete and then upgrading to 7.2.

From one of our users:

After a bit of searching, I came across KB925336 (> http://support.microsoft.com/kb/925336> ), and read about the file-size issue with the windows installer, which I assume is what you were alluding to earlier. I tried the workaround they suggest (modifying HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers\PolicyScope in the registry), and found that this change indeed allows the visual fortran installer to run successfully. (Wooo hooo.)

Although it appears that Microsoft has resolved this issue for Windows 2003 Server, it does not appear they will be fixing it for WinXP. We are currently investigating ways in which we can reduce the size of our install package and hopefully will have a better solution in the near future.

Hope this helps,
Mat

Please look for the KB925336 at: http://support.microsoft.com/kb/925336/en-us

The instructions in the “workaround” section of this Microsoft Article assume that the Registry already contains an entry for PolicyScope in
HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers.

If your machine does not, then create a new entry of type REG_DWORD called PolicyScope. Then edit it by changing the default value of 0 to 1.
Undo the change after the install of the software is completed, as per the instructions in the Microsoft article.

Cheers, Sergio

Hi All,

A user sent us another work-around:

  1. Click Start -> Control Panel
  2. Open Administrative Tools
  3. Open Local Security Settings
  4. Click Software Restriction Policies
  5. If no software restrictions are defined, right click the Software Restriction Policies node and select New Software Restriction Policy
  6. Double click Enforcement
  7. Select “All users except local administrators”
  8. Click OK
  9. Reboot the machine

After installing the package, it is advised that you follow the instructions above to select “All users” in step 6 above.

  • Mat