Installing TensorRT libgie1 issue

Hi there, I am trying to install TensorRT and follow the steps:

sudo dpkg -i nv-gie-repo-ubuntu1404-ga-cuda8.0-gie1.0-20170116_6-1_amd64.deb
sudo apt-get update
sudo apt-get install libgie1

Right there is where I find this error:

The following packages have unmet dependencies:
 libgie1 : Depends: cuda-cublas-8-0 but it is not installable
E: Unable to correct problems, you have held broken packages.

Any tips? I’ve tried aptitue or install -f to try and fix it but can’t seem to find the right thing to do. My nvcc is:
Cuda compilation tools, release 8.0, V8.0.61

please check your operate system version .
This deb package only support for ubuntu 14.04

sudo dpkg -i nv-gie-repo-ubuntu1404-ga-cuda8.0-gie1.0-20170116_6-1_amd64.deb

you need ubuntu 14.04 and cuda 8.0 for ubuntu 14.04

I have Ubuntu 14.04 and Cuda 8.0

Hi, has this issue been resolved ?
I get the same error when i run ‘sudo apt-get install libgie1’

The following packages have unmet dependencies:
     libgie1 : Depends: cuda-cublas-8-0 but it is not installable
    E: Unable to correct problems, you have held broken packages.

Any help is appreciated.

Thanks !

I see the same error. Not sure why it’s not recognizing the cublas library that’s been installed.
one more thing, Does TensorRt support GTX 1080? There is a note mentioned near the TensorRT downloads that it supports Tesla P100, K80, M4, TitanX and Tegra X1. Is anyone aware of this.

Hi bpinaya,

I just tried your installation steps. It’s fine on my machine:

$ sudo apt-get install libgie1
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following extra packages will be installed:
libcudnn5
The following NEW packages will be installed:
libcudnn5 libgie1
0 upgraded, 2 newly installed, 0 to remove and 219 not upgraded.
Need to get 0 B/46.4 MB of archives.
After this operation, 132 MB of additional disk space will be used.
Do you want to continue? [Y/n]

I think you can try again in a fresh environment.

sudo apt-get --remove purge "cuda*" sudo apt-get --remove purge “nv…(related pack)”
sudo apt-get autoremove dpkg -l | grep ^rc | cut -d’ ’ -f3 | sudo xargs dpkg -P

Then install cuda(sudo apt-get install cuda-toolkit-8-0), gie again.

I have not found this error on my machine.

steps:
$sudo dpkg -i cuda-repo-ubuntu1404-8-0-local-ga2_8.0.61-1_amd64.deb
$sudo apt-get udpate
$sudo apt-get install cuda-toolkit-8-0

$sudo dpkg -i nv-gie-repo-ubuntu1404-ga-cuda8.0-gie1.0-20170116_6-1_amd64.deb
$sudo apt-get update
$sudo apt-get install libgie1