Intel 7265 WiFi not working


I tried to get my Intel 7265 WiFi chip working with installing sudo apt install backport-iwlwifi-dkms also tried copying Intel provided drivers at Intel Driver Link into /lib/firmware folder but all these does not make it visible in network settings.

When I look into Additional Drivers in Software & Updates, I see it says Intel Corporation: Wireless 7265; Using iwlwifi driver back port in DKMS format from backport-iwlwifi-dkms (open source). With this shown, doesn’t that mean the driver is working and the WiFi should function well now?

Thank you.

Here is a screenshot of the Additional Drivers tab.

With further research, I have the following traces showing could not load the [0] uCode section.

dlinano@jetson-nano:~$ uname -r

dlinano@jetson-nano:~$ lsmod | grep iwlwifi
iwlwifi 167043 1 iwlmvm
cfg80211 589351 3 iwlmvm,iwlwifi,mac80211
dlinano@jetson-nano:~$ modinfo iwlwifi | grep iwlwifi
filename: /lib/modules/4.9.140-tegra/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko
firmware: iwlwifi-100-5.ucode
firmware: iwlwifi-1000-5.ucode
firmware: iwlwifi-135-6.ucode
firmware: iwlwifi-105-6.ucode
firmware: iwlwifi-2030-6.ucode
firmware: iwlwifi-2000-6.ucode
firmware: iwlwifi-5150-2.ucode
firmware: iwlwifi-5000-5.ucode
firmware: iwlwifi-6000g2b-6.ucode
firmware: iwlwifi-6000g2a-6.ucode
firmware: iwlwifi-6050-5.ucode
firmware: iwlwifi-6000-6.ucode
firmware: iwlwifi-7265D-26.ucode
firmware: iwlwifi-7265-17.ucode
firmware: iwlwifi-3168-26.ucode
firmware: iwlwifi-3160-17.ucode
firmware: iwlwifi-7260-17.ucode
firmware: iwlwifi-8265-26.ucode
firmware: iwlwifi-8000C-26.ucode
firmware: iwlwifi-9000-pu-a0-lc-a0–26.ucode
firmware: iwlwifi-9260-th-a0-jf-a0–26.ucode
firmware: iwlwifi-9000-pu-a0-jf-a0–26.ucode
firmware: iwlwifi-Qu-a0-jf-b0–26.ucode
dlinano@jetson-nano:~$ dmesg | grep iwlwifi
[ 5.700873] iwlwifi 0000:01:00.0: enabling device (0000 → 0002)
[ 6.158081] iwlwifi 0000:01:00.0: loaded firmware version 17.948900127.0 op_mode iwlmvm
[ 6.233418] iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 7265, REV=0xFFFFFFFF
[ 6.234842] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
[ 6.250523] WARNING: CPU: 2 PID: 4649 at /dvs/git/dirty/git-master_linux/kernel/kernel-4.9/drivers/net/wireless/intel/iwlwifi/pcie/trans.c:1860 iwl_trans_pcie_reclaim+0x236c/0x3bb0 [iwlwifi]
[ 6.250538] Modules linked in: iwlmvm(+) mac80211 btusb btrtl btbcm btintel iwlwifi cfg80211 spidev nvgpu bluedroid_pm ip_tables x_tables
[ 6.250566] PC is at iwl_trans_pcie_reclaim+0x236c/0x3bb0 [iwlwifi]
[ 6.250584] LR is at iwl_trans_pcie_reclaim+0x236c/0x3bb0 [iwlwifi]
[ 6.250656] [] iwl_trans_pcie_reclaim+0x236c/0x3bb0 [iwlwifi]
[ 6.250674] [] iwl_write_prph+0x38/0x80 [iwlwifi]
[ 6.250693] [] iwl_trans_pcie_reclaim+0x880/0x3bb0 [iwlwifi]
[ 6.250711] [] iwl_trans_pcie_rf_kill+0xb94/0xe98 [iwlwifi]
[ 6.250779] [] iwl_opmode_deregister+0xba0/0x1410 [iwlwifi]
[ 6.250797] [] iwl_opmode_register+0x74/0xf8 [iwlwifi]
[ 6.291771] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
[ 6.968168] iwlwifi 0000:01:00.0: Could not load the [0] uCode section
[ 6.968187] iwlwifi 0000:01:00.0: Failed to start INIT ucode: -5
[ 8.592374] iwlwifi 0000:01:00.0: Failed to run INIT ucode: -5
[ 8.592389] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled

I have solved it by following this link

Here is the steps:
sudo nano /boot/extlinux/extlinux.conf

Add “pcie_aspm=off” to the end of APPEND line
DEFAULT primary

MENU TITLE L4T boot options

LABEL primary
MENU LABEL primary kernel
LINUX /boot/Image
INITRD /boot/initrd
APPEND ${cbootargs} quiet pcie_aspm=off

Good to know issue resolved, thanks for the update!