Interface Communication MGBE-3 with 1Gigabit Automotive EthernetAnswer Accepted

Software Version
DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)

Target Operating System

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-300)
DRIVE AGX Orin Developer Kit (940-63710-0010-200)
DRIVE AGX Orin Developer Kit (940-63710-0010-100)
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)

SDK Manager Version

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers

We are trying to connect a device (BroadR-Reach, 1000Base-T1) Master device via Quad HMTD to a Nvidia Drive Orin device (P3710) over the MGBE-3 interface.

Connecting the device with a technica media converter (1000Base-T1) to the Ethernet interface (MGBE-1) works as we can observe UDP packages in wireshark.

But we can’t detect any traffic over any port of the MGBE-3 interface although we assign an IP address (ifconfig).

We also used the set_mode_4364 script to manually set the interface to slave mode, but still no traffic observable.

Is there anything we miss?

Thanks and regards

Dear @sebbe,
We will check internally and update you. May I know if you find information about set_mode_4364 script in sdk documentation?

@SivaRamaKrishnaNV thank you very much for your fast reply.

We used the set_mode_4364 script described here:

May I know what device you’re trying to connect? Is it listed on the ecosystem pages?

May I know which quad HMTD connector and port is used? Additionally, could you please confirm that the link is up on the device connected to the HMTD port and that ping is working?

@VickNV thanks for your reply.

We are using the quad HMTD connector right next to the Matenet connector on port 4, but also tried the other one.

After assigning an IP-address the interface is pingable which can be confirmed in wireshark (loopback).

We already cross checked in wireshark, that the device connects to the Orin via MGBE1 (RJ45-11) and media converter. With this configuration it is also possible to ping the device itself (using its IP adress).

Thanks and regards

What is ‘loopback’ here? Additionally, it is not explicitly mentioned whether the device connected to the quad HMTD (port 4) is also pingable through the MGBE-3 interface or not. Clarifying this point would provide a better understanding of your network configuration and help address any potential issues.

@VickNV sorry for not expressing clearly what we meant.

Over the MGBE3 interface we do not observe any sort of communication to or from our device.

We neither observe any communiation in wireshark nor are we able to ping our device, although the network should be configured properly (regarding ip addresses and subnet masks). Additionally, we tried different connections (Quad HMTD J3 & Quad HMTD J4) and ports (1-4 on each connection).

We applied identical network settings to the MGBE1 interface just to check if there is a general communication issue between the Orin and the connected device, but wireshark and ping show the expected behaviour (wireshark reveals receiving UDP packages; ping reaches device).

With ‘loopback’ we meant the internal loopback interface, just to additionally confirm that ping is really working when pinging via the MGBE1 interface.

Does the device connected to Q-HMTD support both 1G and 10G? Any reason for using set_mode_4364 on MGBE-3 interface?

@VickNV sorry for the late reply.

As far as I know the device only supports 1G.

We were not sure if there was some problem with master/slave mode, so we gave it a try and used the set_mode_4364 script on the MGBE3 interface, which seemed to have an effect according to the terminal output.

But unfortunately, we still could not observe any traffic via wireshark.

@sebbe could you share the details on this question?

Is this still an issue to support?
Could you share the details for above question?

@VickNV @kayccc I am sorry for the late reply.
This is no longer an issue to support.
Unfortunately, I cannot share any details.
Thank you very much for your effort and support.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.