"Internal data stream error" is thrown upon running Gstreamer, when using imx283 camera with LI_NANO_CB carrier board and Jetson Nano module

Since not finding any progress on below enquiry. I decided to shift to Jetson Nano from TX2NX.

I am using Tegra version r32.3.1
I have used drivers provided by @SimonZhu and followed the same procedure as in the above mentioned post.

The drivers are sucessfully loaded and video0 ,…video3 are seen in /dev folder.
However I am running into problem. I am getting “i2c write failed” in dmesg if the camera is not connected on their respective ports .
" tegra-vii2c 546c0000.i2c:no acknowledge from address 0x1a
imx283 32-001a: imx283_write_reg:i2c write failed ,30003=77…

**mipi caliberation failed **
caliberation failed with -110 error …."

And when I use Gstreamer to stream video0(to which imx283 is connected ) I am getting "… Internal data stream error…" .
To add to the woes, I am getting same error messege on video1,video2 & video3 (even though camera is not connected on their respective ports)
The Gstreamer command used was "gst-launch-1.o v4l2src device=/dev/video0 ! video/x-raw ,width =1280 ,height=720 , framerate=30/1 ! videoconvert ! autovideosink "
I also have tried height and width of 5496x3694 , 1920x1080 and 640x480

Here is the dmesg file
imx283.txt (89.5 KB)
Any suggestions?? @ShaneCCC @SimonZhu

Please help on this topic.


We prepared a driver guide for LI-NANO-CB + LI-IMX283-MIPI camera.
Please follow the guide to install the driver. The driver works properly on our side.

We are using Nano Som production version with 16GB emmc. The camera works fine on connecting with usb.
I tried implementing what has been instructed in the PDF for “driver installation” .
At the end of 7th step ,I got the video feed.
Also I noticed the dmesg after, copying the prebuilt Image and reebooting . It was same as what I used to get earlier. Also the same gstreamer command highlighted in my previous post was run ,just to run into same error.
Why is it that gstreamer command cannot be run** ??
It runs into “internal stream error” everytime.

I have flashed the Nano with the Image I build by using patch files,also copied the .isp file mentioned in 8th step to /var/nvidia/nvcam/settings/. ,and tried running the command gst-launch-1.0 nvarguscamerasrc sensor-id=0 ! ‘video/x-raw(memory:NVMM), width=(int)5496,height=(int)3694,framerate=20/1’ ! nvvidconv flip-method=0 ! ‘video/x-raw,format=(string)I420’ ! xvimagesink -e .

It runs fine.

Good to know it.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.