Interrupts about nvdia

Now days, I want to bind some certain interrupts to a set cpus. And I run the command:

cat /proc/interrupts

to see the irq number and set the mask :

echo x > proc/irq#/smp_affinity

everything is ok but Nvidia.

So, I run the cat /proc/interrupts again, to check Nvidia’s irq number, But I cann’t find it!

But when I run a cuda application, or just run nvidia-smi command, I can see nvidia’s irq again!

How can this happened? What can I do to solve this problem? any documents recommended?
thanks all

persistence mode?

http://docs.nvidia.com/deploy/driver-persistence/index.html

The GPU driver will unload in between CUDA activity, if persistence mode is not enabled. I haven’t looked at this closely but it would make sense to me that the interrupt is not mapped during the interregnum

Thank you a lot ,this help me . But I don’t know your means by say " interrupt is not mapped during the interregnum"
the interrupt of nvidia can not mapped to centain cpu when CUDA is active?

It would make sense to me that if driver persistence is not enabled, then when CUDA is not active, it may be that the interrupt for the GPU is not mapped.