interval parameter in config file does not work

Hi Guys,

I am trying to use the interval parameter in config_infer_primary_nano.txt and config_infer_primary_yoloV3_tiny.txt but I dont see any change in the output. Kindly let me know how to validate that the parameter is reflected in the application. Following are the changes made :

For tinyyolov3:

[property]
gpu-id=0
net-scale-factor=1
#0=RGB, 1=BGR
model-color-format=0
custom-network-config=yolov3-tiny.cfg
model-file=../models/TinyYolov3/yolov3-tiny.weights
model-engine-file=../models/TinyYolov3/model_b4_fp32.engine
labelfile-path=../models/TinyYolov3/labels.txt
## 0=FP32, 1=INT8, 2=FP16 mode
network-mode=0
interval=5
num-detected-classes=80
gie-unique-id=1
is-classifier=0
maintain-aspect-ratio=1
parse-bbox-func-name=NvDsInferParseCustomYoloV3Tiny
custom-lib-path=../../plugins/nvdsinfer_custom_impl_Yolo/libnvdsinfer_custom_impl_Yolo.so

For resnet10:

[property]
gpu-id=0
net-scale-factor=0.0039215697906911373
model-file=../models/Primary_Detector_Nano/resnet10.caffemodel
proto-file=../models/Primary_Detector_Nano/resnet10.prototxt
model-engine-file=../models/Primary_Detector_Nano/resnet10.caffemodel_b8_fp16.engine
labelfile-path=../models/Primary_Detector_Nano/labels.txt
batch-size=8
process-mode=1
model-color-format=0
## 0=FP32, 1=INT8, 2=FP16 mode
network-mode=0
num-detected-classes=4
interval=5
gie-unique-id=1
output-blob-names=conv2d_bbox;conv2d_cov/Sigmoid
#parse-bbox-func-name=NvDsInferParseCustomResnet
#custom-lib-path=/path/to/libnvdsparsebbox.so
#enable-dbscan=1

According to my understanding, the fps should shoot up but I dont see any change. Kindly help me out.

Thanks.

Hi,

Have you also enabled the tracker?
You will need the tracker component to generate the bbox of non-detector frames.

Thanks.

Hi AastaLLL,

Yes I have enabled tracker. I also see the bounding boxes but the fps does not improve. I am unable to understand why that is the case.

Thanks.

Hi,

Please declare the interval parameter in the primary-gie component.

Ex. edit deepstream_app_config_yoloV3_tiny.txt

[primary-gie]
interval=2
...

I can see the perf result increase from 24.64 to 59.95 with the modification.

Thanks.