Invalid kernel image when compiled with CUDA v4 mac osx, cuda v4

I recently updated my early 2008 mac pro with 2 gtx 285s to CUDA v4 and many programs still work, deviceQuerey and any ptx kernels still work, but basically any program that mallocs any memory seems to fail saying “device kernel image is invalid”.
For example when I run the concurrentKernels demo I get the error : cutilCheckMsg() CUTIL CUDA error : kernel launch failure : device kernel image is invalid.

However if I run programs compiled with the previous CUDA installation it runs fine… Any ideas? I’ve already checked the path and dyd path, and I’ve reinstalled the drivers, toolkit and sdk…
Thanks in advanced,

You probably need to upgrade the device driver. Don’t let yourself be fooled by the Nvidia control panel telling you your driver is up to date (this happened to me…). Go to the download page and get and install the latest driver by hand.

Thanks for the reply. I’ve downloaded the driver and ran the installer a couple times now with the same results. Is there a way to do an clean install though?