Invalid sample name

I want to run using Mutectcaller (Parabricks accelerated) version 4.0.0-2 on UK Biobank Research Analysis Platform. I started analysis and received invalid tumor sample name error. I share a screenshot about input names and log file. In the documentation, I had read “This MUST match the SM tag in the tumor BAM file.” I don’t know what the SM tag in the BAM file I use as input file is. How can I find this?
Can you make a suggestion for tumor sample name?
Many thanks.

Hey @cevikb ,

I was able to find the SM tag on my BAM file using samtools.

Specifically “samtools view -H output.bam”. This printed out a lot of text, but one of the last lines was tagged @RG and had that information. Here’s what mine looked like:

@RG ID:HK3TJBCX2.1 LB:lib1 PL:bar SM:tumor PU:HK3TJBCX2.1

Hopefully that helps!

Hi @gburnett ,

Thank you very much for your answer. I could find SM tag of my BAM file in the log file using FQ-to-BAM Pipeline (Parabricks accelerated).


I tried to run again with a few sample names;

Name of sample for tumor reads. (tumor_name)

Name of sample for tumor reads. (tumor_name)

Name of sample for tumor reads. (tumor_name)

but I received invalid sample name error Is there other advise?

Thanks in advance.

Hey @cevikb,

Based on the output you shared, it looks like the sample name is “sample”. Have you tried that?


I tried just “sample” and It worked. Thank you for your useful comment.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.