Is Bluetooth/BLE and BlueZ supported in the L4T R32.3.1 docker image?


I’m on Jetpack 4.3 on a Jetson Nano DevKit and using a USB bluetooth dongle.

When starting the container, I run:
docker run --runtime nvidia --gpus all --ipc host --privileged -e DISPLAY=$DISPLAY -v /tmp/.X11-unix:/tmp/.X11-unix -u root --cap-add=SYS_ADMIN --net=host -it cvision/nano:latest bash

After successfully installing BlueZ 5.54 onto a container running on the L4T R32.3.1 image, I run:

$ /etc/init.d/dbus start
$ /usr/local/libexec/bluetooth/bluetoothd --debug &
$ bluetoothctl

Then try to scan:

[bluetooth]# scan on

Which gives me: No default controller available.

btmon shows:

= New Index: <mac addr> 7 (Primary,USB,hci0)
= Open Index: <mac addr>

From the host device, running scan on in bluetoothctl will scan for devices. Also in the host device I have access to hcitool and hciconfig where in the L4T image I do not.

Has anyone successfully been able to use Bluetooth and BLE in a container?

Update: I solved this. Just need to turn off the bluetooth service on the host: service bluetooth stop. Seems that this was conflicting with the container.