Is it possible to flash Xavier with an Ubunto running to Virtualbox?

As the topic states, is it possible to use Virtualbox running Ubuntu to flash Xavier without having to get a dedicated laptop running Ubuntu to load Jetpack onto it?

Yes. I’ve been doing that. Ubuntu 18.04 on a vmware fusion vm running on osx host

However, I did not manage to get internet working on the target via the USB-C connection to the host. Unsure if this is a vm specific issue as I have seen others with linux hosts also complain about it. Workaround is to use the ethernet connection

Officially flashing Xavier from VM is not supported. However, in certain cases it works, but requires to do some customization of Virtualbox settings. I had to attempt flashing ~10 times before I distinguished the way that worked for me in my environment.
What worked for me, as far as I remember was:

  1. use usb3 controller in usb settings of virtualbox
  2. use usb device filter

However, you may find multiple posts at the forum with more details on the issue, in my opinion.

Do you mean the Xavier Wifi module doesn’t work and requires internet connection through ethernet cable directly connected to Xavier?

Seems strange to not be consistent…
Would a Raspberry Pi with Ubuntu loaded on it work for flashing what I need onto it?

There’s no in-built wifi on xavier. The dongle I used didn’t have a supported preinstalled driver so it wasn’t available at install time. The two available options are

  1. usb-c with the host acting as a router (didn’t work for me)
  2. ethernet

How do you know after you attempt a flash that it ‘didn’t work for you’? Did it give an inconsistent error message until the 10th time?