Is it possible to install ISAAC SDK in a windows machine with 5.1 cc?

I wanted to try out the ISAAC SDK on my laptop. I do not have a workstation. I’m using a windows 10 machine with Nvidea Geforce gt 840 4gb which has a compute capability of 5.1. Is there any chance I could install and use some parts of the SDK?

Isaac SDK requires Ubuntu 18.04 and is not officially supported on Windows WSL2… but you could try it I suppose.

Okay. I’m able to run isaac using wsl. All the sample cpp apps can be run using wsl, but the python apps are giving me errors.
Also, i was wondering if it is possible to run isaac on an Ubuntu 18.04 system without nvidia gpu?

That’s great! Strange that Python is problematic though. You would think that what would work out-of-the-box considering Python is platform agnostic.

Isaac SDK links against CUDA 10.2 which you wouldn’t have installed without an NVIDIA GPU.

im curious to know if there is a team looking to make the WSL2 guide to install (maybe with some tweaked plug-in) or you know the standard isaac just versioned to use with WSL2 . or maybe install on a ubuntu 18.04 machine with the Gpu being on a (wired-to) machine…

Im not sure what ROS is too is it another OS ??
might have to go dual boot to get a bit more conformtable with linux and to ger to know it better. Any recommendation ?

I tried running ISAAC on WSL2. It works fine, but I had an issue where I couldn’t run any python applications. I’m not sure why.
But after that I installed ubuntu 18.04 as dual boot along with windows. I allocated about 50gb for linux. I did that exact same steps I did for installation and isaac works well in ubuntu. I’m now able to run all python apps as well.
I’m new to linux as well. It’s not that hard. A lot of tutorials for linux is also available online. Give it a go!

i gotta ask…why is that the only part of Omniverse that is dual-boot or no-go for windows user.

This is a bit weird too since it seems that many poeple are able to make it work with the wsl2 easily but not quite perfectly.

(in my case i dont even know how to try it on Wsl2) …