Is it possible to install TensorRT on Ubuntu 22.04

Description

Hey everyone, i am trying to install tensorrt in ubuntu 22.04 but i have found only some packages for ubuntu 18.04 and 20.04.
Should i took the package with the name linux_x86_64 ???

Or it’s not possible to use TensorRT in Ubuntu 22.04 yet ?

Environment

GPU Type: NVIDIA RTX 3060
Operating System + Version: Ubuntu 22.04
Python Version (if applicable): 2.7

Thank you for your answers

Hi,
Please refer to the installation steps from the below link if in case you are missing on anything

Also, we suggest you to use TRT NGC containers to avoid any system dependency related issues.

Thanks!

Thank your for your answer, i’ve followed the link you provided me, but i’ve found only 18.04 and 20.04 Ubuntu TensorRT packages.

I tried installing nv-tensorrt-repo-ubuntu2004-cuda11.6-trt8.4.0.6-ea-20220212_1-1_amd64.deb on Ubuntu 22.04. There was a problem when trying to install python3-libnvinfer_8.4.0-1+cuda11.6_amd64.deb and
python3-libnvinfer-dev_8.4.0-1+cuda11.6_amd64.deb. I am getting a dependency error:

@grinev i think using a realease of tensorrt which was made for ubuntu 20.04 will not work on ubuntu 22.04. And i guess that they will make a release of tensorrt for ubuntu 22.04. So we have to wait until this release is available or downgrade to ubuntu 20.04 ^^

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.