Is it possible to run Isaac sdk on Nvidia Xavier without host pc?

I am trying to run Isaac sdk on Nvidia Xavier without host PC.
So I tried running

engine/build/scripts/install_dependencies.sh

and

engine/build/scripts/install_dependencies_jetson.sh -u <jetson_username> -h <jetson_ip>

on Nvidia Xavier.
But I am facing some difficulties.
Firstly, I got gcc-aarch64-linux-gnu and has g+±aarch64-linux-gnu no installation candidate.
And I could not successfully install bazel. I am getting

Exec format error

And also the first script gives

error of could not find a version that satisfies requirement of tensorflow-gpu==1.13.1

Is there any alternate way to run Isaac sdk without host PC, where I can compile the packages and run them directly in Xavier?
Any kind of help is appreciated

virajshah.vs ISAAC SDK is not meant to run on a Jetson, rather you need to run it on a Linux workstation or virtual machine. The documentation at https://docs.nvidia.com/isaac/isaac/doc/setup.html#prerequisites provides you with information about system requirements.

The ISAAC SDK will then allow you to deploy the application easily on a Jetson target.

Hi I am using the NVIDIA Kaya robot reference model for my class, I was wondering, is it necessary to have a NVIDIA GPU installed in the host PC’s that the students will be using to program these robots using the Isaac SDK. I am looking at using the Isaac SDK 19.2, GEMS and a virtualized Ubuntu 18.04 installation.

Unfortunately, my lab PC’s will not be updated for another two months, at which point all the machines will than have 32GB and RTX 2070’s installed.

Do we need to put Xavier in recovery mode for this? Documentation is not the best…

Ilengyel, NVidia GPU’s are required for the work with some of the GEMs but not for all of them. But, the installation will require CUDA and Nvidia drivers to be present.

Seord, I am not sure I understand the question. To deploy an Isaac application on xavier you remotely log in to the Xavier from the workstation/host PC. The Linux system needs to be running at the time. A Xavier in recovery mode will not be detected/reachable.

CFR I meant for the installation as for the initial setup we need to put it in recovery mode to port the SDK’s to the Xavier. But I think you mean the same thing, I will try it now. If I run into any issues I will post back.

Thanks

seord, any further update?

Hello, I am trying to develop code using Isaac SDK on a Jetson Xavier (connected to monitor etc) and wanted to check if there is still a requirement for the Isaac SDK to be run on a Linux workstation? There is a section in the setup documentation which installs dependencies on Jetson products so I tried using that but I am not able to use bazel so I don’t think the installation was successful.