is necessary flash JETSON TK1 ?

IS NECESSARY FLSH JETSON TK1?
IF I ONLY WILL WORK WITH:

OPENC CV
PYTHON
QT
C++
CUDA
AND OTHERS BASIC SOFTWARE…

NOTHIG MORE…

Hi cristian_ortiz,

The OpenCV and CUDA you can install via JetPack.

The latest Jetpack3.1 download from: https://developer.nvidia.com/embedded/dlc/jetpack-l4t-3_1
Install guild: http://docs.nvidia.com/jetpack-l4t/3.1/index.html#developertools/mobile/jetpack/l4t/3.1/jetpack_l4t_install.htm

thanks Carolyuu!

but is necessary flash the JETSON TK1… ???

because i want install direct on the Jetson TK1… WITHOUT FLASH… :(

The TK1 arrives with a working operating system (L4T R19.2…which is Ubuntu 14.04). Flash is not mandatory. However, this version is not particularly reliable, and “relatively” newer versions of CUDA may be available on the newer version. There is no possibility of installing an updated Linux for Tegra operating system (basically Ubuntu) without flash, and there is no flash possible directly from the Jetson. This older version uses the fastboot boot loader, and any changes to the base kernel requires flash. If you flash once to the newer version (L4T R21.5, which is Ubuntu 16.04), then it uses U-Boot instead of fastboot…you get a very significant increase in reliability, software compatibility, and the ability to modify the kernel without further flash (U-Boot makes kernel development possible without flashing). Flashing once is not mandatory, but it is difficult to imagine development (or even basic use) without one flash.

thanks linuxdev!

then is necessary for develop the jetson tk1… i’ll try flash jetson tk1 for a more efficiency and not have any problem in a future…

THANKS :)