Is NVENC really supported on Linux?

I recently switched to a Quadro K620 card in hopes that NVENC would work with it, but I’m met with the same error while initializing that I got with my GeForce.

Can somebody from NVidia please confirm if NVENC is truly supported on Linux? If so, please provide card model that is known to work. :)

$ sh 

>> GetNumberEncoders() has detected 1 CUDA capable GPU device(s) <<
  [ GPU #0 - < Quadro K620 > has Compute SM 5.0, NVENC Available ]

>> InitCUDA() has detected 1 CUDA capable GPU device(s)<<
  [ GPU #0 - < Quadro K620 > has Compute SM 5.0, Available NVENC ]

>> Select GPU #0 - < Quadro K620 > supports SM 5.0 and NVENC

 nvEncoder Error: NVENC H.264 encoder initialization failure! Check input params!

Edit: More Details

Cuda SDK/Toolkit: 6.5.14
Driver: 343.22 (in bug report)
nvidia-bug-report.log.gz (125 KB)


On Linux, NVENC is currently only supported on certain NVIDIA Quadro, Tesla, and GRID products. We are in the process of validating Linux NVENC support on all Kepler and newer GPUs. This additional support will be provided in a future driver release.

Hi Sandip,

So I guess that the Quatro K620 doesn’t fall in the “certain NVIDIA Quadro” category.

Could you please clarify which card models DO work?

Thanks again,

We have had some luck with k600’s on 64 bit linux…until we didn’t.

We have a k1000, a k2000, as well as a Tesla K20.

NVEnc worked fine up to driver 325.15.

After that, NVEnc is broken in all our kepler quadro cards, including our very expensive Tesla card.

So, use a Kepler card such as the k600, and the 325.15 driver.

Since the rpms from different vendors get updated along with the kernel, you will need to blacklist the other nvidia drivers and compile your own nvidia driver each time you update your kernel.