Is there a driver (even a beta) for the Quadro K1100M? (SOLVED)

Hey, I have a new Dell M3800, which has a Quadro K1100M in it. I have installed Ubuntu 14.04 (development-branch) on it, and my current driver is, of course, the Intel® Haswell Mobile driver.

I’d like to use this GPU for Linux-based software development. I looked for the appropriate driver from the website and found no drivers, not even a beta…

From the updates on this forum it looks like there was support for this card in the 331.17 (beta) version and 319.72 version of the driver, however looking through their ‘supported devices’ the K1100M is not listed. (See: https://devtalk.nvidia.com/search/more/sitecommentsearch/K1100M/) and fail to install (see post below…)

Which driver should I be using? Will there be better support on this GPU in linux in the future?

All of these fail to install…

331.38-nvidia-installer.log (158 KB)
319.72-nvidia-installer.log (144 KB)
331.17-nvidia-installer.log (112 KB)

Found a way to make this thing work! This worked for my K1100M inside of 14.04 as of the release this morning. Patching or starting in the middle of the following steps ( without purging ) did not result in favorable results.

If you end up in low-graphics mode, just get to the ttyal, by hitting Crtl-Alt-Delete & F1. Login with your regular credentials and proceed:

For sake of completeness make sure all x services are shutdown, you can list all services by:

sudo service --status-all

To stop them ( and please be careful of the ‘*’ depending on your set up )

sudo service x* stop

( at this point when you look at the status of all x-related services a ‘-’ should be next to them )

Next you should remove all existing and potentially conflicting nvidia packages. I’d welcome corrections to this step if anyone knows the packages that are conflicting.

sudo apt-get remove nvidia-* 
sudo apt-get install nvidia-prime 
sudo apt-get install nvidia-331 
sudo nvidia-xconfig

The above basically removes all potential conflicts, installs the nvidia-prime service ( and starts it ), installs a driver( hopefully compatable with your device ), and then afterwards asks the Xserver to probe the devices to create a proper configuration.

For the sake of completeness: restart your computer.

** note upon login to a “working system” you’ll receive notifications that the system detected errors, these are probably a combination of all the errors accumulated during your “attempting to fix it” time and existing problems already reported based on the incompatibility of your driver.

You got it working, but how is the performance running with the nvidia card? I have very bad performance. Only 220 with glmark2. With the Intel card I get 2400.