Is there a manual way to add components to TX2 after flashing Jetpack 4.2?


I’m trying to flash my TX2 with Jetpack 4.2 with SDK Manager. I set it in recovery mode, and it flashes successfully and I go through and set up configuration manager on the TX2. Then, when I try to install components, I get the error message unable to connect to target. I’ve checked my usb connections and they all fail, but only when it comes to installing the components.

Then, I tried just running on my host machine, and the TX2 still flashed successfully. I set everything up, but I’m wondering if there is a way to install the components manually? I’ve been struggling with the SDK Manager for some time now so I just want to install the components like CUDA etc manually like I did with previous Jetpacks and be done with it.

Thank you for your help!

So I tried manually installing all the deb found in sdkm_downloads folder on the host machine (scp them to the target, then dpkg -i). However, when I try to find libcudart*, it seems that it is missing from /usr/local/cuda-10.0/lib64. I see libcublas10.0* and libvlas10.0, but no cudart. Is there a way for me to find this library? Do I need to do anything with any of the .zip or .tbz2 in the sdkm_downloads folder? Any help would be greatly appreciated.

Thank you!

(Sorry, the above comment posted multiple times)

(Sorry, the above comment posted multiple times)

Hi st585,

After flash completed, please remember to do inital setup process till system boots to the Linux desktop. (connect HDMI to your device) Then enter the same username and password to continue install SDK components.

Below is install CUDA by manually steps:

cp cuda-repo-l4t-10-0-local-10-0.166_1.0-1_arm64.deb from your download folder
cp from older JetPack folder/_installer
mkdir -p cuda-l4t
sh cuda-repo-l4t-10-0-local-10-0.166_1.0-1_arm64.deb