IsaaC NX has been released

https://developer.nvidia.com/isaac-sdk-2020-1-nx
https://developer.nvidia.com/isaac-sdk-docs-2020-1-nx
does it have more sensors supported than earlier osaac releases?
iz zed2 supported?

Moving to ISAAC forum for resolution.

Hi Andrey,
You can use Zed 2, though our team tested only with Zed Mini.
No other new sensors added to this release. However, we do have support from our ecosystem partners.
What specific sensor would you like to see support for?

whhat is the status of support og AGX with Jetpack 4.4 ?
is it covered by the NX release?

zed2;
intel realsense d435i
intel realsense t265
intel realsense l515
As per my tests zed2 failed running with IsaaC. Moreover Intel realsense d435 only worked with an year old obsolete firmware version; Neither d435i not t265 or l515 are supported

after installing dependencies to robot the last line of the execution at Host PC before the reboot is:

You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
environment: line 13: jupyter: command not found

is the jupiter something that will need to be troubleshooted? Tried deployment to AGX with 4.4.GA
Also despite the message [rebooting Jetson device] the Jetson device wouldn’t reboot

Hi, @Andrey1984,
Jetpack 4.4 is covered by NX release;
Zed2 is not supported yet;
For Jupyter on Jetson, not sure why the installation failed. You may want to try to install it manually with
python3 -m pip install --user numpy jupyterlab matplotlib Pillow
as shown in install_dependencies_jetson.sh script.

@yangl
Thank you for following up!
The installation with pip executed at Jetson shows that all componnents are in place;
However, in case I execute the install depenndencies from Host PC;
at the tail it wold show

Requirement already satisfied: pyparsing>=2.0.2 in /usr/lib/python3/dist-packages (from packaging->bleach->nbconvert->notebook>=4.4.1->widgetsnbextension~=3.5.0->ipywidgets) (2.2.0)
WARNING: You are using pip version 20.2; however, version 20.2.2 is available.
You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
environment: line 13: jupyter: command not found

restart referenced in the tail

Rebooting the Jetson device

won’thappen also
However, execution of command explicitly on jetson terminal seems succeeding

 jupyter nbextension enable --py widgetsnbextension
Enabling notebook extension jupyter-js-widgets/extension...
      - Validating: OK

I will try on another AGX/NX unit with J.P.4.4GA

do we have integrration of zed2 into the most recent isaac release 2020.2?

We have been able to run a ZED2 here successfully with Isaac SDK 2020.2 on a pre-Ampere GPU (NVIDIA Quadro T2000), but I have not tried it myself.

1 Like

Thank you for following up!
It would be great if these steps could be shared in order to try isaac 2020.2 on Desktop PC wiith RTX2080
which zed sdk version is required?
I tried 2020.2 on Jetson AGX with ZED2, but the isaac sight just shows black rectangles
trying with zed sdk 3.3.3 on Host PC with 2020.2 isaac
At the host PC running the zed_camera app will result in web sight page just showing left camera also right camera streams;
In Isaac 2020.1 there was an application for depth rendering from two zed images as I understand that is not presented in 2020.2.
//apps/samples/stereo_matching_depth

Have you already tried the ZED2 with ZED Explorer from the ZED_SDK from Stereolabs to make sure the camera is configured properly?

Are you referring to //sdk/apps/samples/stereo_rectification perhaps?

Thank you for following up
The rectiified runs,

bazel run //apps/samples/stereo_rectification

showing left, also right sensors streams.
We were also able to run

bazel run packages/visual_slam/apps:svo_zed_imu
bazel run packages/visual_slam/apps:svo_zed
bazel run //packages/orb/apps/orb_demo

all three latter will run wiith zed2;
However, the depth image for zed2 doesn’t come up with any of the four apps listed above. ZED explorer should work. Will try with it also
@hemals I meant this https://docs.nvidia.com/isaac/isaac/packages/stereo_depth/doc/c2f-stereo-depth.html
Maybe you also could elaborate on how to run the sample on liive camera, not using the default staic image sample for https://docs.nvidia.com/isaac/isaac/packages/skeleton_pose_estimation/doc/2Dskeleton_pose_estimation.html ?

Yes, you’re right, the sample //apps/samples/stereo_matching_depth relied on the ZedCamera codelet to emit the stereo pair of images and then mapped the disparities through //packages/stereo_depth:coarse_to_fine. However, it appears that in 2020.1NX onwards, the stereo depth estimation packages (and that sample app) had been removed because they were unmaintained when moving to JetPack 4.4. The ZedCamera codelet itself explicitly disables depth processing in the StereoLabsSDK driver itself, so Isaac SDK has no access to the depth image rectified from elsewhere either. I am investigating our options still.