ISAAC SDK 2020.1 Desktop dependencies requirement.txt error

While installing dependencies on the Desktop using dependencies script , i am getting this error , requirement.txt file in /engine/build

ERROR: Could not find a version that satisfies the requirement tensorflow-gpu==1.15.0 (from -r engine/build/scripts/requirements.txt (line 1)) (from versions: 2.2.0rc1, 2.2.0rc2, 2.2.0rc3, 2.2.0rc4, 2.2.0, 2.2.1, 2.3.0rc0, 2.3.0rc1, 2.3.0rc2, 2.3.0, 2.3.1)
ERROR: No matching distribution found for tensorflow-gpu==1.15.0 (from -r engine/build/scripts/requirements.txt (line 1))

Does this have anything to do with my CUDA version ? Any leads wil be appreciated.

@ishanbhatnagar6434
You are using the wrong Python version.
As you can read here: https://www.tensorflow.org/install/pip, tensorflow(-gpu)<=1.15.0 only run on Python 3.5-3.7. And Python 3.8 requires tensorflow>=2.2.0.

So my best guess is, you are using Python 3.8 and not 3.7.

If your systems requires Python 3.8, try using a virtual environment for Python.

Yes Johann, you were absolutely right , i set up a virtual Python 3.6 environment in conda and setup went ahead with no errors.

Happy to hear!

Please mark the question as answered for other people looking for a solution to a similar problem. Thank you :)