Isaac SDK 2020.1 + Isaac Sim 2020.1: TCP Connection Timeout

Hi all,

I’m trying to launch the Omniverse/SDK “Warehouse Navigation with Carter” sample
https://docs.nvidia.com/isaac/isaac/doc/simulation/ovkit.html#warehouse-navigation-with-carter
with the following setup:

1. Omniverse Isaac Sim 2020.1 app via Omniverse Launcher [Natively installed]
i) Open the sample scenario omni:/Isaac/Samples/Isaac_SDK/Scenario/carter_warehouse_with_forklifts_*stereo*.usd (the regular version seems to be broken)
ii) Activate the robot engine bridge:
isaac-utils >> robot engine bridge and press ‘create application’ button

2. Launch the SDK inside a Docker Container (see Getting Started — ISAAC 2021.1 documentation)
i) Start docker container with forwarded gpu and dedicated ports:
docker run --mount source=isaac-sdk-build-cache,target=/root -v pwd:pwd-wpwd/sdk --gpus all -p 3000:3000 -p 8888:8888 -p 55000:55000 -p 55001:55001 -it isaacbuild:latest /bin/bash
ii) Run the SDK application:
bazel run apps/navsim/navsim_navigate -- --map_json apps/assets/maps/virtual_test_warehouse_1.json

The SDK application seems to return a tcp issue (see the txt file for the full output)
WARN packages/engine_tcp_udp/components/TcpSubscriber.cpp@158: Failed to connect to remote. Will try again in 0.500000 seconds.

console_output (62.1 KB)

Hi Julian,
Can you try running docker with the flag –network=host

Hi Teresa,
Thanks! Indeed, replacing the specific port exposure with --network=host solves this issue!

PS: @Teresa Maybe it might be helpful for folks to update the docker setup in this regard, especially w.r.t. using

  • --gpus all (instead of deprecated --runtime=nvidia) and
  • --network=hostadded for the gateway to Isaac SIM.
1 Like

For the record:
The docker container has to be started using the following attributes:

docker run --mount source=isaac-sdk-build-cache,target=/root -v pwd:pwd-wpwd/sdk --gpus all --network=host -it isaacbuild:latest /bin/bash

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.