Isaac SDK 2020.1 Unable to run navsim_navigate

As I go through the unity3D navsim_navigate example in the documentation, I do build with no error yet I get error as given below (undefined symbol: IsaacGatherComponentInfo):

2020-06-06 14:08:43.286 ERROR engine/alice/backend/modules.cpp@250: packages/perception/libperception_module.so: /home/user/.cache/bazel/_bazel_user/4d6740c5aa839e158ceb13b5e0e4e670/execroot/com_nvidia_isaac/bazel-out/k8-opt/bin/apps/navsim/navsim_navigate.runfiles/com_nvidia_isaac//packages/perception/libperception_module.so: undefined symbol: IsaacGatherComponentInfo
2020-06-06 14:08:43.286 PANIC engine/alice/backend/modules.cpp@252: Could not load all required modules for application

| Isaac application terminated unexpectedly |

Does anyone experienced this problem?

Thanks

I turned out that the cuda version used to be 11. This was the problem. After I install cuda version 10 the problem solved due to undefined symbol: IsaacGatherComponentInfo

1 Like

I needed cuda 10.1, strangely cuda 10.0 did not help with the exact same error, so I installed 10.1 following these steps https://medium.com/@exesse/cuda-10-1-installation-on-ubuntu-18-04-lts-d04f89287130

1 Like

For me, this worked as well (even though $nvidia-smi still tells me that cuda version 11.0 is installed).

I installed cuda v. 10.0 with $sudo apt install cuda-10-0