Isaac-SDK Build Error

Hi,

I ran bazel build packages/ping:ping and I get the following response:

INFO: Repository com_github_nelhage_rules_boost instantiated at:
  no stack (--record_rule_instantiation_callstack not enabled)
Repository rule http_archive defined at:
  /home/cedric/.cache/bazel/_bazel_cedric/cf0901af49b98d012b345d211e80e29c/external/bazel_tools/tools/build_defs/repo/http.bzl:336:16: in <toplevel>
WARNING: Download from https://developer.nvidia.com/isaac/download/third_party/rules_boost-82ae1790cef07f3fd618592ad227fe2d66fe0b31-tar-gz failed: class com.google.devtools.build.lib.bazel.repository.downloader.UnrecoverableHttpException GET returned 404 Not Found
ERROR: An error occurred during the fetch of repository 'com_github_nelhage_rules_boost':
   java.io.IOException: Error downloading [https://developer.nvidia.com/isaac/download/third_party/rules_boost-82ae1790cef07f3fd618592ad227fe2d66fe0b31-tar-gz] to /home/cedric/.cache/bazel/_bazel_cedric/cf0901af49b98d012b345d211e80e29c/external/com_github_nelhage_rules_boost/rules_boost-82ae1790cef07f3fd618592ad227fe2d66fe0b31-tar-gz.tar.gz: GET returned 404 Not Found
ERROR: no such package '@com_github_nelhage_rules_boost//boost': java.io.IOException: Error downloading [https://developer.nvidia.com/isaac/download/third_party/rules_boost-82ae1790cef07f3fd618592ad227fe2d66fe0b31-tar-gz] to /home/cedric/.cache/bazel/_bazel_cedric/cf0901af49b98d012b345d211e80e29c/external/com_github_nelhage_rules_boost/rules_boost-82ae1790cef07f3fd618592ad227fe2d66fe0b31-tar-gz.tar.gz: GET returned 404 Not Found
INFO: Elapsed time: 3.452s
INFO: 0 processes.

The response is the same if I try building other sample apps like stereo_dummy.

Some further info:

  1. I am building using WSL Ubuntu 18.04
  2. I’ve tried creating a .bashrc file in the ~/isaac/sdk folder bu the error persists.
  3. Connectivity to developer.nvidia.com is okay

Any ideas on where I could be going wrong?

Hi @kiplimock,

This looks to be related to an outage that we are having with our CDN. Unfortunately we don’t have an ETA for when this will be fixed. I will post here when we are up and running.

Thanks for your patience,
Tom K

Hi @TomK,

Okay. I guess I’ll have to wait. Thanks.

Hello,

I am happy to report that all assets have been reloaded and files are now available for download. Thanks for your patience.

Cheers,
Tom K