Isaac SDK Webinar tutorial app terminates when run

Hello, I am new to Isaac SDK and I am watching the recording of the webinar “Creating Intelligent Machines with the Isaac SDK”.

Before the webinar, I have downloaded SDK 2019.3, done the prerequisites and run the stereo_dummy sample as described in All works fine and I can access the running app in the browser.

However, when following the webinar and running the app my_goal_generator_test it terminates without doing anything and without any errors. This is the result, after which the app terminates and it returns back to the console:

~/isaac-sdk$ bazel run //apps/tutorials/
INFO: Analysed target //apps/tutorials/ (0 packages loaded, 0 targets configured).
INFO: Found 1 target...
INFO: Elapsed time: 0.168s, Critical Path: 0.00s, Remote (0.00% of the time): [queue: 0.00%, setup: 0.00%, process: 0.00%]
INFO: 0 processes.
INFO: Build completed successfully, 1 total action
INFO: Build completed successfully, 1 total action

I have tried a number of times, did comparisons with the code in the webinar, with the code in some samples, and did online research for similar problems, but without any success.

Practicing all as it is in the webinar will be really helpful for me to get started with Isaac. Any suggestion what could be the reason for this problem will be great. Thanks in advance.

Hi dspetrov,
The correct way of running the app is
bazel run //apps/tutorials/webinar_1:my_goal_generator_test without the .app.json at the end

Hi TeresaC,
Thanks for the answer. I tried an it works now.