Isaac Sim 2019.2 Issue with opening carter maps and robot builder map.

Hello fellow developers and Nvidia!
The other topic was marked resolved by user PROTOTYPE. The issue with Isaac Sim 2019.1 was resolved with a temporary solution proposed by @sergey and @z-zhang (thanks guys, I was able to get 2019.1 to work).

The proposed final solution from Nvidia - updated SDK and XML - was released this morning, but the same issue is still there.

I am starting another topic specifically for this problem in the 2019.2 version.

I am using:

  • UnrealEngine-IsaacSim_1.2
  • isaac-sdk-2019.2-30e21124
  • IsaacSimProject_1.2.gitdeps.xml
  • When I start up the Carter Sim or the Robot Builder Map using:

    ~/Documents/2019.2/UnrealEngine-Isjavascript:void(0);aacSim_1.2$ ./Engine/Binaries/Linux/UE4Editor IsaacSimProject RobotBuilder -vulkan

    UE4 shows an error message:Failed to open map file. This is most likely because the map was saved with a newer version of the engine.

    Tony Kam

    Hi Tony,

    As I mentioned in the other thread, I believe, you are half on on new and half on old version somehow.
    We have moved the location of some maps and assets, so if you are not completely build the new package, it will look for somewhere for the map based on the old release.

    My suggestion is to start clean, download and build.

    Please let us know if you still have problem,

    Hi Liila!

    Sorry for the delayed response. I no longer have the problem. I was able to get 2019.2 version to work! I uninstalled and started clean. Thank you for the suggestion.

    Tony Kam


    I started from scratch but I still get this error:

    Failed to open map file. This is most likely because the map was saved with a newer version of the engine.

    Hi Behzad,

    Most probably, you like Tony have a mix of old and new installation.
    We have moved the location of the map in the updated version and that is why it can not find them.

    Please start clean and then should work fine.

    Hope this helps,

    Thank Liila. I follow these steps:

    git clone --single-branch --branch IsaacSim_1.2
    cd UnrealEngine
    rm Engine/Build/IsaacSimProject_1.2_Core.gitdeps.xml
    cp ~/Download/IsaacSimProject_1.2.gitdeps.xml Engine/Build
    make && make IsaacSimProjectEditor

    Have I missed anything?

    This time, it worked! Thank you!

    Hi Behzad,

    I am glad you got it working, please don’t hesitate to ask any questions you have.


    can you tell me how to clean my installation, very thanks

    Hi GuaXiong

    Create a new folder, and start from the first step.

    Hope this helps