Isaac sim crash when I click the "play" button

I just installed Isaac sim 2022.2.1. The computer system is Win11 and the GPU is RTX 3090.

But when I open the Isaac sim and click the play button (without any other action), the program crashes. Here is the output error, did someone see the error before? It would be great if you could tell me how to fix it. thanks in advance!

Here is the log file:
kit_20230914_104831.log (1.1 MB)

By the way, I installed VS 2019 before. here are some modules I installed.

@StayStack i am just another user, so bear with me.

  1. first, i would look into disabling the two display drivers form Intel. you can do this by going into your device manager, disabling those under “display adapters”
  2. for future reference, you can get the log from C:\Users\%username%\.nvidia-omniverse\logs\Kit\Isaac-Sim. uploading to your thread should save you from having to take consecutive screenshots
  3. try to match the driver version to the recommended version specified in the Issac Sim doc (even if you have to downgrade) to see if it helps

Thanks for your reply!

I follow your advice to downgrade the driver and disable two display drivers from Intel, but it still crashes when I run the application. I have uploaded the log file instead of the screenshots.

Thanks for your help and advice again!

was it working before today or has it been crashing since the first time launching the app? also, what’s the renderer you are using when you hit play? RTX-Realtime or Interactive?

It can work a few days before, but the app can’t work after I installed ROS2. The renderer is RTX-Realtime, I just tried Interactive mode, and it still failed.

it does look like you have ROS2 extension set to autoload. can you try disabling autoload to see if it’s related, then disabling the extension altogether if the issue persist. (i am not sure if this is the source of the problem, but just trying to rule something out)

1 Like

Yes! ROS2 extension is the problem source! When I close the extension, everything is fine. If I activate ROS2 on cmd before I run the app, the app can also run under the ROS2 extension. Thanks a lot for your help :)

1 Like

ah, good to know. thanks for reporting back! 👍

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.