Isaac Sim installation by Launcher stuck at

Did you try to go full screen before everything is loaded? that some times lead to exit

No, I didn’t. If it happens again later. I’ll post again. Thanks~

1 Like

I have the same issue, please find enclosed the launcher log and the post install log.
I tried to wait for hours but nothing is changing. I also tried to reinstall everything a couple of time but same result. (8.6 KB)

Do you have any clues about what is causing this issue and how cant it be solved ?

Thank you very much !

Please find here the launcher log

launcher_log2.txt (22.7 KB)

I have the same problem. Waiting for installing OMNI.ISAAC.SIM.POST.INSTALL.SH but nothing happens.

Do the latest Code and Create work for you?
When installing Isaac Sim, a terminal window may pop up during the post install. You could try force close this window and let the post install skip building the shaders. The install should complete soon.
The shader warm up will then be run on first launch of Isaac Sim instead.

We recommend installing Nucleus and Cache before installing Isaac Sim. Please follow the setup instructions.

What I did was commenting out the warmin up cache related codes from once omniverse launcher unzips the It solves the installing issue now Isaac Sim is installed and I have it in my APPS in omniverse-launcher, but same as Code and Create I can’t launch it. Here is the log when I launch it manually by running (I have also attached the log right here kit_20230107_013819.log (448.3 KB))

[Info] [carb] Logging to file: /home/elyar/.nvidia-omniverse/logs/Kit/Isaac-Sim/2022.2/kit_20230107_013819.log
2023-01-07 09:38:19 [47ms] [Warning] [omni.ext.plugin] [ext: omni.drivesim.sensors.nv.lidar] Extensions config ‘extension.toml’ doesn’t exist ‘/home/elyar/.local/share/ov/pkg/isaac_sim-2022.2.0/exts/omni.drivesim.sensors.nv.lidar’ or ‘/home/elyar/.local/share/ov/pkg/isaac_sim-2022.2.0/exts/omni.drivesim.sensors.nv.lidar/config’
2023-01-07 09:38:19 [47ms] [Warning] [omni.ext.plugin] [ext: omni.drivesim.sensors.nv.radar] Extensions config ‘extension.toml’ doesn’t exist ‘/home/elyar/.local/share/ov/pkg/isaac_sim-2022.2.0/exts/omni.drivesim.sensors.nv.radar’ or ‘/home/elyar/.local/share/ov/pkg/isaac_sim-2022.2.0/exts/omni.drivesim.sensors.nv.radar/config’
[0.270s] [ext: omni.stats-0.0.0] startup
[0.315s] [ext: omni.rtx.shadercache-1.0.0] startup
[0.330s] [ext: omni.assets.plugins-0.0.0] startup
[0.331s] [ext: omni.gpu_foundation-0.0.0] startup
2023-01-07 09:38:20 [322ms] [Warning] [carb] FrameworkImpl::setDefaultPlugin(client: omni.gpu_foundation_factory.plugin, desc : [carb::graphics::Graphics v2.11], plugin : failed. Plugin selection is locked, because the interface was previously acquired by:
[0.339s] [ext: carb.windowing.plugins-1.0.0] startup
[0.347s] [ext: omni.kit.renderer.init-0.0.0] startup

For my part I switched from Ubuntu 22.04 to Ubuntu 20.04 and after a long time of installation it worked.
I am a bit disapointed that Isaac does not work with Ubuntu 22.04 but let’s just wait some time until devs make it work.
Also for information the issue was before the terminal window pop up and I had Nucleus and Cache installed.
32Gb Ram
RTX 3070 8Gb VRam with Drivers 525
i5 12gen

Thank you very much.

1 Like

Finally I could solve the problem. The problem was my laptops integrated Intel graphics. I just selected NVIDIA (Performance Mode) in PRIME Profile of NVIDIA X Server Settings. I think the screen was connected to intel GPU instead of NVIDIA before and Isaac Sim needs screen to be connected to NVIDIA graphics. Thanks everyone.

1 Like

I am having the same issue.
RTX 3080, Driver 520, Cuda 11.8, Isaac Sim 2022.2.0.

I have nucleus and cache installed, I was upgrading from 2022.1.1 when this failure occurred.

Isaac Sim locks up on:

2023-01-09 01:13:41 [216ms] [Warning] [carb] FrameworkImpl::setDefaultPlugin(client: omni.gpu_foundation_factory.plugin, desc : [carb::graphics::Graphics v2.11], plugin : failed. Plugin selection is locked, because the interface was previously acquired by: 
[0.223s] [ext: carb.windowing.plugins-1.0.0] startup
[0.228s] [ext: omni.kit.renderer.init-0.0.0] startup

and no more logs are produced. Installation was only possible by skipping warming up the cache entirely - and even then it still will not launch as it gets stuck on omni.kit.renderer.init-0.0.0. Omniverse Create, Code, and Isaac Sim all fail to launch.

On a desktop, pretty sure it’s not attaching to an integrated gpu. I’ve tried reinstalling Isaac Sim 2022.2.0, and 2022.1.1 - both fail with the same error.

I have tried driver versions 515, 520, and 525, with cuda 11.7, 11.8, and 12.0 - all fail.

I just tried today to run Isaac sim in a docker container instead of natively and I had the same issue that you had. In the container Isaac was stuck at the same line.
I found on a previous thread on this forum another way to launch the container that solves the issue for me. As you mentioned it, it does not use the cache.

Command to run :
docker run --name isaac-sim --entrypoint bash -it --gpus all -e “ACCEPT_EULA=Y” --rm --network=host

Unfortunately this command does not works with Isaac sim 2022.2.0, I have a segmentation fault.

Link to the thread:

Currently Isaac Sim 2022.2.0 is not supported on Ubuntu 22.04. We will be looking into it for the Isaac Sim 2023 versions.

@gabriel.garcia Here is the command to run Isaac Sim 2022.2.0:

docker run --name isaac-sim --entrypoint bash -it --gpus all -e “ACCEPT_EULA=Y” --rm --network=host
-v /etc/vulkan/icd.d/nvidia_icd.json:/etc/vulkan/icd.d/nvidia_icd.json
-v /etc/vulkan/implicit_layer.d/nvidia_layers.json:/etc/vulkan/implicit_layer.d/nvidia_layers.json
-v /usr/share/glvnd/egl_vendor.d/10_nvidia.json:/usr/share/glvnd/egl_vendor.d/10_nvidia.json
-v ~/docker/isaac-sim/cache/ov:/root/.cache/ov:rw
-v ~/docker/isaac-sim/cache/pip:/root/.cache/pip:rw
-v ~/docker/isaac-sim/cache/glcache:/root/.cache/nvidia/GLCache:rw
-v ~/docker/isaac-sim/cache/computecache:/root/.nv/ComputeCache:rw
-v ~/docker/isaac-sim/logs:/root/.nvidia-omniverse/logs:rw
-v ~/docker/isaac-sim/config:/root/.nvidia-omniverse/config:rw
-v ~/docker/isaac-sim/data:/root/.local/share/ov/data:rw
-v ~/docker/isaac-sim/documents:/root/Documents:rw

This works if /etc/vulkan/icd.d/nvidia_icd.json exits. You may need to update this mount path if the path to that file on host is different (due to different OS or drivers).

See our docs for latest info.


This gave me a hint in the right direction actually.

By default, if

  • /etc/vulkan/icd.d/nvidia_icd.json
  • /etc/vulkan/implicit_layer.d/nvidia_layers.json

don’t exist docker automatically creates them as a directory, and once they exist as a directory it causes omniverse kit to hang - without emitting any sort of error.

I manually removed those two file paths entirely (after validating they were, in fact, directories) - and Omniverse Create will now launch correctly, and I can install and run Isaac Sim 2022.2.0.
It is better to modify the recommended docker launch script to something along the lines of:

    docker run --name isaac-sim --entrypoint bash -it --gpus all -e “ACCEPT_EULA=Y” --rm --network=host
    -v /etc/vulkan/icd.d:/etc/vulkan/icd.d
    -v /etc/vulkan/implicit_layer.d:/etc/vulkan/implicit_layer.d
    -v /usr/share/glvnd/egl_vendor.d:/usr/share/glvnd/egl_vendor.d
    -v ~/docker/isaac-sim/cache/ov:/root/.cache/ov:rw
    -v ~/docker/isaac-sim/cache/pip:/root/.cache/pip:rw
    -v ~/docker/isaac-sim/cache/glcache:/root/.cache/nvidia/GLCache:rw
    -v ~/docker/isaac-sim/cache/computecache:/root/.nv/ComputeCache:rw
    -v ~/docker/isaac-sim/logs:/root/.nvidia-omniverse/logs:rw
    -v ~/docker/isaac-sim/config:/root/.nvidia-omniverse/config:rw
    -v ~/docker/isaac-sim/data:/root/.local/share/ov/data:rw
    -v ~/docker/isaac-sim/documents:/root/Documents:rw

and then have isaac sim check those mounted volumes. Alternatively, using --mount instead of --volume as recommended by docker would correct this issue: Bind mounts | Docker Docs

I quote:

Experienced users may be more familiar with the -v or --volume syntax, but are encouraged to use --mount, because research has shown it to be easier to use.

If you use -v or --volume to bind-mount a file or directory that does not yet exist on the Docker host, -v creates the endpoint for you. It is always created as a directory.


I was also facing the same issue using cuda 11.6.2 which came with driver version 11.10.x on ubuntu 20.04.5. However, it is stated here that that version of driver won’t work. Updated cuda to 11.7.1 with driver 515.65.01. The installation happens cleanly now and I am able to start Isaac Sim.

1 Like

I have the same problem. Install gets stuck on omni.isaac.sim.warmup.kit with 100% cpu usage on 1 thread. I tried uncommenting the warmup in the post install script, but then the same hanging occurs when trying to launch isaac

@josiah.bull Thanks. That makes sense. I’ll give it a try and update the documentation.

@vardanagarwal16 Which driver version were you running before. Take a look at our requirements here.

@b-vm You can try close the terminal window during installation to skip the warmup script. Please share you log files if you are still having issues.

After I gave up on my attempt of installing Isaac Sim yesterday I noticed it actually caused other issues with /lib/x86_64-linux-gnu/ file throwing seg faults when other programs(mujoco) tried to use it. Also vulkaninfo threw segfaults

I just deleted the etc/vulkan folder and vulkaninfo and mujoco work again now.

Before I try it all again I would like to confirm the issues were not caused by my RTX 3050 Ti 4 GB? I know 8 GB is required by the docs, but not sure if it would cause an issue upon install.

Sounds good. Yes, deleting the /etc/vulkan folder before a driver install should help.

I think you may be able to install with that GPU by closing the warm up terminal but you may have issues when running Isaac Sim.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.