Isaac sim installation fails on a multi-gpu system

Installing isaac-sim fails as shown below when running on a machine with 2 GPU (1 GTX 1650 + 1 RTX 2080Ti)

./isaac-sim.sh
[Info] [carb] Logging to file: /home/mn/projects/isaacsim/_build/target-deps/kit_sdk_release/_build/linux-x86_64/release/data/Kit/isaac-sim/2020.2.28460/omniverse-kit.log
2021-01-29 23:16:03 [1ms] [Warning] [omni.kit.app.plugin] [Graphics API] Vulkan

[0.049s] [ext: omni.timeline-0.1.0] startup
[0.070s] [ext: omni.kit.async_engine-0.1.0] startup
[0.100s] [ext: omni.assets-0.1.0] startup
[0.100s] [ext: omni.kit.test-0.1.0] startup
[0.108s] [ext: omni.usd-0.1.0] startup
[0.374s] [ext: omni.client-0.1.0] startup
2021-01-29 23:16:03 [366ms] [Warning] [carb] Acquiring non optional plugin interface which is not listed as dependency: [carb::tokens::ITokens v0.1] (plugin: (null)), by client: omni.client.plugin. Add it to CARB_PLUGIN_IMPL_DEPS() macro of a client.
[0.384s] [ext: omni.kit.registry.nucleus-0.1] startup
[0.387s] [ext: omni.kit.pipapi-0.1.0] startup
[0.475s] [ext: omni.stats-0.1.0] startup
[0.477s] [ext: omni.kit.pip_archive-0.1] startup
[0.486s] [ext: omni.appwindow-0.1.0] startup
[0.499s] [ext: omni.ui-1.0.0] startup
[0.514s] [ext: omni.kit.commands-0.1] startup
[0.523s] [ext: omni.ansel-0.1.0] startup
[0.524s] [ext: omni.renderer-0.1.0-rtx] startup
[0.524s] [ext: omni.kit.selection-0.1] startup
[0.617s] [ext: omni.kit.editor-0.1.0-full] startup
2021-01-29 23:16:04 [953ms] [Warning] [gpu.foundation] Raytracing is not supported on GPU: 0. Skipping this device.

|---------------------------------------------------------------------------------------|
| Driver Version: 450.102
|=======================================================================================|
| GPU | Name | Active | GPU Memory | Vendor-ID | LUID |
| | | | | Device-ID | UUID |
|---------------------------------------------------------------------------------------|
| 0 | GeForce GTX 1650 | | 4342 MB | 10de | 0 |
| | | | | 1f82 | 67e1cce6… |
|=======================================================================================|
| Processor: AMD Ryzen 9 3900X 12-Core Processor | Cores: Unknown | Logical: 24
|---------------------------------------------------------------------------------------|
| Total Memory (MB): 64332 | Free Memory: 53113
| Total Page/Swap (MB): 2047 | Free Page/Swap: 2047
|---------------------------------------------------------------------------------------|
2021-01-29 23:16:04 [972ms] [Error] [gpu.foundation] No device could be created.
2021-01-29 23:16:04 [972ms] [Error] [omni.kit.plugin] createGpuFoundation() failed.
/home/mn/projects/isaacsim/_build/linux-x86_64/release/isaac-sim.sh: line 4: 13410 Segmentation fault (core dumped) “$SCRIPT_DIR/…/…/target-deps/kit_sdk_release/_build/linux-x86_64/release/omniverse-kit” --merge-config="SCRIPT_DIR//experiences/isaac-sim.json" @

Here is the result of nvidia-smi

Fri Jan 29 15:16:21 2021
±----------------------------------------------------------------------------+
| NVIDIA-SMI 450.102.04 Driver Version: 450.102.04 CUDA Version: 11.0 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 GeForce RTX 208… Off | 00000000:0A:00.0 Off | N/A |
| 27% 31C P8 21W / 260W | 1MiB / 11019MiB | 0% Default |
| | | N/A |
±------------------------------±---------------------±---------------------+
| 1 GeForce GTX 1650 Off | 00000000:0B:00.0 On | N/A |
| 50% 28C P8 9W / 75W | 589MiB / 3908MiB | 8% Default |
| | | N/A |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
|=============================================================================|
| 1 N/A N/A 1265 G /usr/lib/xorg/Xorg 309MiB |
| 1 N/A N/A 1474 G /usr/bin/gnome-shell 194MiB |
| 1 N/A N/A 2182 G …mviewer/tv_bin/TeamViewer 2MiB |
| 1 N/A N/A 7975 G …gAAAAAAAAA --shared-files 79MiB |
±----------------------------------------------------------------------------+

Hi please try running Isaac Sim with the following flags:

$ ./isaac-sim.sh --/renderer/activeGpu=0 --/renderer/multiGpu/maxGpuCount=1

You could also try running in docker:

xhost +local: sudo docker run --entrypoint ./runapp.sh --gpus ‘“device=0”’ -e “ACCEPT_EULA=Y” --rm -v /tmp/.X11-unix:/tmp/.X11-unix -v /etc/localtime:/etc/localtime:ro -e DISPLAY=unix${DISPLAY} --network=host nvcr.io/nvidia/isaac-sim:2020.2.2_ea

Is it possible to remove the GTX 1650 and is the RTX 2080Ti on an eGPU?
Please also make sure that the RTX 2080Ti is connected to a monitor.