Isaac Sim Unity3D 2020 Undefined Symbol

2020-06-22 11:45:39.587 ERROR engine/alice/backend/modules.cpp@250: packages/perception/ /home/quinn/.cache/bazel/_bazel_quinn/45ceef10643edb54ee4d30316b79ded3/execroot/com_nvidia_isaac/bazel-out/k8-opt/bin/apps/navsim/navsim_navigate.runfiles/com_nvidia_isaac//packages/perception/ undefined symbol: IsaacGatherComponentInfo
2020-06-22 11:45:39.587 PANIC engine/alice/backend/modules.cpp@252: Could not load all required modules for application

I get this error when running “bazel run //apps/navsim:navsim_navigate” from the Unity3D Isaac Sim 2020 page
My CUDA version is CUDA Version 10.0.130

I am using a Virtual Machine to run Ubuntu 18.04 and I have installed the nvidia 440 graphics card driver. Also my Graphics card is a GTX 1060.

What should I do?

Hi, @qlevine,

Reading from the error message, it is likely that some dependencies is missing. Would you please re-install all dependencies and try again.

Thanks for the reply, I will go ahead and try that.

So I reinstalled the dependencies, and now I am realizing that I may need to do a PCI passthrough so that Vulkan can use my graphics card. Is that correct? I have no idea how to do a PCI passthrough and from some quick research it looks like it could be dangerous to my computer if I do it incorrectly. Any thoughts on the best way to go about this?

This is not related to vulkan since it comes from isaac sdk, not unity, and isaac sdk itself do not rely on vulkan.
When this happen it’s usually cuda, cudnn or trt is not installed or incorrect version. In isaac folder, run

python3 engine/build/scripts/

to make sure the versions are all correct.

1 Like

We have the same undefined symbol issue even without any kind of Virtual Machine. We have Nvidia 450.36.06 driver version on the host, and a Xavier freshly set up with latest SDK Manager.

Previously with Isaac 2019.3 we were successful running many examples. But with 2020.1 it seems that something is either missing a dependency or maybe something got upgraded that shouldn’t have.

We re-installed dependencies on host and on Xavier, that didn’t help. We cleaned Bazel and re-deployed after dependencies, that didn’t help either. The “realsense-camera” and “stereo-dummy” examples work but “carter” and “follow-me” seem to compile fine on the host but issue the undefined symbol error in

qianl Thank you for the suggestion to run the checker. In our case, it shows everything is ok but we still have the error

The python version checker showed no version for Cudnn here (N/A). Will see if this resolves the missing symbol problem here. Is Cudnn supposed to be installed by the dependency script?

Edit: Installing CuDNN did not help. I see some other posts saying that Cuda 10 is required, and Cuda 10.1 and 10.2 may not work. I had 10.2 here.

For Ubuntu, install Cuda-10-0.

@cobraviaee we also thought CUDNN was to blame but like you we found that installing it didn’t resolve the issue. We were able to resolve our issue with the method shown in the post below, basically by making sure Jetpack 4.3 is installed on the target which automatically installs CUDA 10.0

I had this same issue on a new install of Isaac 2020.1. I was able to get this fixed by installing Cuda 10.0 and cudnn and checking the version checker script to make sure i met all the requirements. I also had to add the following line to my ~/.bashrc file.

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/cuda-10.0/lib64

Once I added that I launched a new terminal and everything worked fine after that. Hopefully this helps you out


For those with the same Vulkan issue as me, I ended up needed to use Teamviewer to remote into the Ubuntu computer rather than remote desktop. This allowed me to run Vulkan successfully.

did it work? i had cuda10.2 and my checker showed cudnn N/A too

could you tell me your vesion of jetpack? did it work with the target when depolying the software on Xavier?

reinstall cuda10.0 worked

Had the same problem. Installing Cuda 10.0 solved the issue. Note that you dont need to uninstall previous Cuda installations. For reference:

Reinstall cuda10.0 also worked. Note that only install nvidia driver using apt worked for me. My nvidia driver version is 450.80.02.