Isaac Sim Unity3d Sample was aborted

Hi, I am new to Isaac. I was trying to run the Isaac tutorial of building Issac Applications and I had no problems until the “Start Unity3D” step. I ran the sample simulation with command “./sample.x86_64 --scene small_warehouse -logFile -” however the sample is aborted. The stdout is below:

Set current directory to /home/bob/isaac_sim_unity3d/builds
Found path: /home/bob/isaac_sim_unity3d/builds/sample.x86_64
Mono path[0] = '/home/bob/isaac_sim_unity3d/builds/sample_Data/Managed'
Mono config path = '/home/bob/isaac_sim_unity3d/builds/sample_Data/MonoBleedingEdge/etc'
Preloaded ''
Preloaded ''
Display 0 '0': 1920x1080 (primary device).
Unable to load player prefs
Desktop is 1920 x 1080 @ 60 Hz
[Vulkan init] extensions: count=0
Caught fatal signal - signo:11 code:1 errno:0 addr:(nil)
Obtained 1 stack frames.
#0             (nil) in (Unknown)
Aborted (core dumped)

I have already added this line
export VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json
to the bashrc file but the sample is still aborted. I am using my local pc with a Nvidia RTX2070super. Below is the result of “python3 engine/build/scripts/” .

|OS                  |Ubuntu 18.04.5 LTS  |
|Bazel               |N/A                 |
|GPU_Driver          |450.80.02           |
|Cuda                |10.2.89             |
|Cudnn               |            |
|TensorRt            |N/A                 |
|TensorFlow          |1.15.0              |
|pycapnp             |0.6.4               |
|librosa             |0.8.0               |
|SoundFile           |0.10.3.post1        |
|Python2             |2.7.17              |
|Python3             |3.6.9               |

I have already installed Bazel 3.1.0 and when I ran command bazel version, the info is shown as

Build label: 3.1.0
Build target: bazel-out/k8-opt/bin/src/main/java/com/google/devtools/build/lib/bazel/BazelServer_deploy.jar
Build time: Wed Apr 22 10:32:27 2020 (1587551547)
Build timestamp: 1587551547
Build timestamp as int: 1587551547

I am not sure why Bazel version is not shown when running version_checker.

I have only skipped the step Installing Dependencies on Robots of Isaac Setup.
Thank you in advance for any suggestions!

Solved. I initially installed Nvidia Driver using .run file directly downloaded from the Nvidia website. However it turned out that only driver installation through PPA would have Vulkan installed. In addition, driver 440 didn’t work with my pc and only driver 455(after deleting 440) make everything works fine.

1 Like