Issac Gym: Enable 'Render Collision Meshes' option by default for viewer

In the IssacGym viewer, how can you enable the ‘render collision mesh’ option by default through code?

IssacGym rendering is very slow when rendering actual visual meshes, as compared to when render collision meshes. (Idk why this is the case, maaaybe it is specific to my robot due to a complicated visual mesh, or maybe due to my lower spec’d hardware Laptop with 1650Ti). However to bypass this, once the rendering starts, you can navigate to the ‘Viewer’ tab of the GUI and enable rendering of collison meshes. This speeds up the simulation by a lot (10fps to 40+fps).

When tinkering and tweaking environemnts, this becomes frustrating as every run you have to perform the same, and even the GUI interface lags with the simulation. Is there any way to enable this by default through code, so the viewer render the collison meshes by default without us changing anything?

I have tries the below approached based on the documentions, but both havn’t seemed to work -

  1. While creating the viewer using create_viewer(), passing camera properties which has ‘use_collision_geometry’ property set to True
  2. In the draw_viewer() function, pass the ‘render_collision’ argument as True.

Please let me know if there is any other way I should try to acehive the same, or anything else I might be doing in the pipleline elsewhere?

1 Like

Anyone has ideas?