Issac Sim 2023.1.1 freezes issue

I run the 2023.1.1 version of Issac Sim on Ubuntu 22.04,and the Computer specs are good to run
the Issac Sim software freezes when I run my python script for no reason,and I couldn’t see the errors on Terminal because It didn’t log any when the software freezes.

1 Like

@2221002057 i am just another user and have a few inquiries:

  1. what’s your GPU driver version?
  2. what does your script do, running simulations in standalone?
  3. it could be related to the dataset that you are working with that is inhibiting you from having a smooth experience with Isaac Sim, if you are ruling out hardware and not having errors in the console. is that the case here?
  4. out of curiosity, how long have you waited for the app to return responsiveness, if it ever manages to do that? there were other users experiencing long load time due to shader compilations when using standalone - Isaacsim hangs when I hit play for any simulation - Omniverse / Isaac Sim - NVIDIA Developer Forums
2 Likes

Hi there,

I would like to resume this conversation to understand if anyone could help.

We have a similar problem. Our simulation (wrapped in a python script) especially if run as a standalone application rather than an extension, freezes for no reason.

I will answer @Simplychenable questions in our case:

  1. driver version 525.85.12 with CUDA 12.0
  2. the script loops over a bunch of configuration values, for each configs instantiate a clear stage and iteratively steps the simulated world until a certain condition is reached. In that case, the stage is cleared and instantiated with the next config.
  3. not sure what you mean
  4. it never manages to exit. The entire system freezes, even the internal clock. Syslog does not report anything at all.

At first we thought the iterative loop on the config values could potentially lead to issues but it does not. We tested the loop with a standalone app example shipped with IsaacSim and that works.

Also, the same script with the same IsaacSim version installed on a different machine with Ubuntu 20 does not freeze.

Thanks in advance for the support.

1 Like