Issue connections by wifi

I configured the wifi using info in follow topic:
https://devtalk.nvidia.com/default/topic/1068759/jetson-nano/not-able-to-connect-to-home-wifi-using-headless-mode-/post/5414485/?offset=14#5414667

and I installed a rdp server using that:
https://www.makeuseof.com/tag/how-to-establish-simple-remote-desktop-access-between-ubuntu-and-windows/

it works fine, but if I restart the device I found that i’m not able to connect in remote desktop or start connection with SSH by wifi if I don’t start the jetson with USB cable and Ethernet cable already connected.

There are some operations to do to avoid that?

it works fine, but if I restart the device I found that i’m not able to connect in remote desktop or start connection with SSH by wifi if I don’t start the jetson with USB cable and Ethernet cable already connected.

I don’t see any connection between wifi and usb cable/ethernet cable. Are you able to use serial console to dump log and see what happens?

Also, is rdp related to this issue?

Yeah, I can open it. Wich log do you need?

Some news about that? I definitively found that without starting a previous USB connection, I’m not able to use remote desktop. I don’t know how to check the issue, because if I connect with the USB to verify where is the problem, it works. Did someone has similar problem?

Sorry for late reply. I think we should narrow down this issue first.

Your problem: I found that i’m not able to connect in remote desktop or start connection with SSH by wifi if I don’t start the jetson with USB cable and Ethernet cable already connected.

Issue 1. Are you able to see wifi if you don’t have usb/ethernet cable?
Issue 2. What is the exactly one that would affect? the ethernet cable or usb cable or both of them?
Issue 3. Does wifi a must-have to reproduce this issue? What would happen if you use ethernet to connect?

I’m thinking that the issue was related to my wifi router. I changed the router and connected using ip instead host name and now it looks to work fine.