Issue Disabling SMMU on Xavier NX

I’m trying to use openPowerlink (GitHub - OpenAutomationTechnologies/openPOWERLINK_V2: Release 2 of the openPOWERLINK protocol stack) on my Xavier NX with ConnectTech’s Quark carrier which has an i210 Intel NIC on it. Unfortunately, the driver for powerlink appears to have difficulties with the SMMU (I’m guessing due to the kernel messages received). I’ve found conflicting advice on how to disable the SMMU (eg pcie smmu issue - #6 by vidyas) but seem to have been unable to as most of the patches found don’t apply cleanly.

Does anyone know what the method to disable the SMMU would be in 32.7.2?

Of course, I should also try to fix the driver, assuming this is in fact my issue. The same driver does work properly on an x86 host.

Please refer to below thread to see if can help: How to disable IOMMU on Xavier NX? - #20 by vidyas

Thanks for the reply. It appears drivers/iommu/arm-smmu-t19x.c no longer exists (see drivers/iommu - linux-4.9 - Gitiles) - is it now using the generic arm-smmu.c? If so, it would appear that there is the “disable_bypass” option which seems to do the same thing (and more!). Should this flag be used instead?

I take it there is no need for the bootloader modification mentioned in pcie smmu issue - #7 by WayneWWW any more then as well?

Which driver code are you referring to? If you are still using jp4.x version software,then I don’t think there is much difference.

I mean these changes are still needed and driver code may still be there.

I’m using the tegra-l4t-r32.7.1 tag for the kernel (jp4.6, I belive) from the 4.9 kernel and drivers/iommu/arm-smmu-t19x.c doesn’t exist there. Am I using the wrong kernel base?

The file is under nvidia repo. Not k4.9 repo.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.