in the instruction of “running isaac sim for the first time”, there is a section called " SIMPLIFYING THE MODEL". It asked me to drag /Root/chassis/electronics into /Root/chassis/body, but it does not allow me to do so. In the Console of Isaac sim, it outputs “Cannot move/rename ancestral prim /Root/chassis/electronics”.

1 Like

Screenshot from 2021-03-28 14-48-35

Hope this can give more hints to solve the problem.

1 Like

Before this, when I tried to use STEP importer, after I click “Finish Import”, I can’t click “Save Flattened”. I can only do it after I select “Built in Step Files”.

1 Like


It seems you can not move/delete, etc. because the entities on your stage are references of external USD models… To modify them, you need to save the model as flattened (Save Flattened) to merge all components into one .usd. Then, open and work on this previously saved and flatten model…


Thank you. It works now.

Hi Toni,

I was trying to import urdf, and regroup it in USD. But , terminal report the error “cannot move/rename ancestral prim/world/mera_model/lsr_link”.
I was trying to re-import mera_urdf by flatting the USD. But there is no “flatten ” button in URDF import window?


Please note that when importing a URDF, the imported asset will be added to the current stage (cleared or not) as a reference (orange icon, in the Stage panel).

To edit the imported URDF, go the output directory (same as source directory by default) and open the generated .usd file.

In any case, you can always save the current stage as flattened using the File > Save Flattened As… menu

Thank you Toni. It works now. I got it , I need one more step to flat it but not from import URDF window.